2003 Chevrolet Tahoe service brake system

Tiny
SLIM63
  • MEMBER
  • 2003 CHEVROLET TAHOE
  • 5.3L
  • V8
  • 2WD
  • AUTOMATIC
  • 275,000 MILES
Warning comes up in message center. I have checked fluid, pad thickness, both are fine up front. The front left caliper does seem to rub a bit but not enough to stop from turning. Doesn't pull either way. Got an idea of where I might need focus on?
Do you
have the same problem?
Yes
No
Saturday, February 7th, 2015 AT 11:25 AM

5 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Have you scanned the computer to see if there are any trouble codes? It may deal with an ABS sensor.
Was this
answer
helpful?
Yes
No
-1
Saturday, February 7th, 2015 AT 12:03 PM
Tiny
SLIM63
  • MEMBER
Yeas I have a scanner, nothing on the abs. I havent had the ABS problems son people speak of online.
Was this
answer
helpful?
Yes
No
Saturday, February 7th, 2015 AT 12:06 PM
Tiny
SLIM63
  • MEMBER
Yes I have a scanner and nothing on the abs system. I haven't had the ABS problems some people have spoke of online.
Was this
answer
helpful?
Yes
No
Saturday, February 7th, 2015 AT 12:09 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
That makes it tough. Since the brakes are good, there are no ABS codes, and the fluid is full, you need to start checking wiring in the system.

NOTE: I assume this isn't a parking brake light, correct?
Was this
answer
helpful?
Yes
No
+2
Saturday, February 7th, 2015 AT 12:16 PM
Tiny
SLIM63
  • MEMBER
Na, it shows in the message center. And that damn buzzer goes off 15 or 20 times.
Was this
answer
helpful?
Yes
No
+1
Saturday, February 7th, 2015 AT 12:19 PM

Please login or register to post a reply.

Sponsored links