No spark, no fuel

Tiny
CHRIS GOULD
  • MEMBER
  • 1998 DODGE RAM
  • 5.9L
  • V8
  • 4WD
  • AUTOMATIC
  • 106,093 MILES
I have the 1500 model. I do not have spark or fuel. Have checked all fuses and relays multiple times. New crank sensor, new coil. New fuel pump. Odometer flashing and throws codes 920 and 921. I am able to jump the fuel pump off the relay terminal but still no fire.
Do you
have the same problem?
Yes
No
Tuesday, July 18th, 2017 AT 12:26 AM

13 Replies

Tiny
HMAC300
  • EXPERT
Try a security system reset. I think on your car you lock drivers door with key, unlock with key then try to start. Other wise try the link that is attached. kind of sounds like a security problem.
https://www.2carpros.com/articles/how-to-reset-a-security-system
Was this
answer
helpful?
Yes
No
+1
Tuesday, July 18th, 2017 AT 5:45 AM
Tiny
CHRIS GOULD
  • MEMBER
Tried that still no spark or fuel pump kicking on. Even installed a different PCM still same exact thing
Was this
answer
helpful?
Yes
No
+1
Thursday, July 20th, 2017 AT 4:26 PM
Tiny
HMAC300
  • EXPERT
If the new pcm wasn't programmed to your truck it won't start anyhow
check fuses and asd relay under hood
Was this
answer
helpful?
Yes
No
Thursday, July 20th, 2017 AT 5:03 PM
Tiny
CHRIS GOULD
  • MEMBER
Even if the PCM is out same yr with same motor? Have checked & fuses & relays multiple times, all good.
Was this
answer
helpful?
Yes
No
Thursday, July 20th, 2017 AT 9:04 PM
Tiny
HMAC300
  • EXPERT
Yes because the pcm's have a security system and if it is not programmed to your truck then it won't start. you should scan for codes with OLD computer and check fuel pressure with a gauge auto parts rent it. see link.
https://www.2carpros.com/articles/how-to-check-fuel-system-pressure-and-regulator
Was this
answer
helpful?
Yes
No
Friday, July 21st, 2017 AT 6:40 AM
Tiny
CHRIS GOULD
  • MEMBER
No codes with old computer. Just says error when I put a scanner on. And there is no fuel pressure because the fuel pump doesn't kick on
Was this
answer
helpful?
Yes
No
Friday, July 21st, 2017 AT 12:55 PM
Tiny
HMAC300
  • EXPERT
You may have a broken wire or connector where you plug scanner in try another one if you have one available. see link for no start as well it may be a security issue too with old computer in truck and hooked up did you try the security reset by locking/unlocking driver door that I first sent?
https://www.2carpros.com/articles/car-cranks-but-wont-start
Was this
answer
helpful?
Yes
No
Friday, July 21st, 2017 AT 1:13 PM
Tiny
CHRIS GOULD
  • MEMBER
Yes I did, multiple times. Ok I'll try & get another scanner
Was this
answer
helpful?
Yes
No
Friday, July 21st, 2017 AT 3:29 PM
Tiny
CHRIS GOULD
  • MEMBER
Hooked another scanner, a more advanced one. Still read error. The truck acts like it wants to start but just continues to turn over
Was this
answer
helpful?
Yes
No
Sunday, July 23rd, 2017 AT 1:12 PM
Tiny
KEN
  • ADMIN
Hello,

It sounds like you may have an ASD relay that is bad here is a guide and some wiring diagrams to help you do some more testing.

https://www.2carpros.com/articles/how-to-check-an-electrical-relay-and-wiring-control-circuit

and

https://www.2carpros.com/articles/how-to-use-a-test-light-circuit-tester

Please let us know what happens.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Monday, July 24th, 2017 AT 3:16 PM
Tiny
CHRIS GOULD
  • MEMBER
All relays are good. Now all of a sudden I have fuel pump but doesn't just prime. It stay on continuously. But still no spark. Pls help!
Was this
answer
helpful?
Yes
No
+1
Monday, July 31st, 2017 AT 10:35 PM
Tiny
KEN
  • ADMIN
It sounds like its time to do a pin to pin check on the computer to see if you have all the power and grounds are working. Use the wiring diagram above.

https://www.2carpros.com/articles/how-to-check-wiring

Please let us know what you find.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Wednesday, August 2nd, 2017 AT 10:50 AM
Tiny
CHRIS GOULD
  • MEMBER
As far as I could tell everything was ok. Still no spark & fuel pump stays on doesn't just prime. Have replaced wiring harness, pcm, crank sensor, cam sensor, idle air sensor, tps. Odometer still flashes & throws codes 920 & 921
Was this
answer
helpful?
Yes
No
Monday, August 7th, 2017 AT 6:37 PM

Please login or register to post a reply.

Recommended Guides