Engine Hot A/C Off!

Tiny
MRMRSSWEETP
  • MEMBER
  • 1 POST
  • 2008 PONTIAC TORRENT
  • 6 CYL
  • AWD
  • AUTOMATIC
  • 75,000 MILES

I have a 2008 Pontiac torrent, my- Engine Hot- A/C Off - came on and my temp gauge on the dash fell down on cold instead of up on hot. Why? I checked all fluids and they were fine, did not smell hot.

Do you
have the same problem?
Yes
No
Wednesday, January 26th, 2011 AT 10:40 PM

2 Replies

Tiny
MICHELLEWB1
  • MEMBER
  • 1 POST

I had the exact same issue this morning with my 2008 Torrent (87000 miles)! The remote start kicked off after running for about two minutes and then after driving about a mile, the check engine light came on with the "engine hot a/c off" message. Temp gage never moved from cold and when I got to work (about 30 miles) the engine fan continued to run after I shut the vehicle off. Could it need a new thermostat? I also checked fluids and they are fine
.

Was this
answer
helpful?
Yes
No
-1
Tuesday, January 24th, 2012 AT 5:41 PM
Tiny
KEN
  • ADMIN
  • 13,875 POSTS

Hello,

This sounds like one of two problem either you have a stuck thermostat or the engine coolant temperature sensor is not working right. Here are two guides that should help you get the problem fixed.

https://www.2carpros.com/articles/coolant-temperature-sensor-cts-replacement

and

https://www.2carpros.com/articles/replace-thermostat

Please let us know what you find. We are interested to see what it is.

Cheers, Ken

Was this
answer
helpful?
Yes
No
Monday, January 29th, 2018 AT 1:05 PM

Please login or register to post a reply.

Recommended Guides