Cruise control.

Tiny
SEAN03
  • MEMBER
  • 1992 CADILLAC DEVILLE
  • 135,000 MILES
Hey cadieman. I worked on the cruise control today. I put the switch back in and connected it. I made it to where you cannot blow through it unless you toch the brake. The yellow cruise light still does not come on. What do I need to do now. Will the yellow light come on if I drive it or should it come on when I start it up. The cruise on the lever is set to on but the light wont come on. At one point this car was broken into. Some one tried to steal it but couldnt. They tore a bunch of wires out under the steering colum. We had to buy a new collum and ignition cylinder because they broke that to. Thanks.
Do you
have the same problem?
Yes
No
Wednesday, July 4th, 2012 AT 5:55 PM

136 Replies

Tiny
CADIEMAN
  • MEMBER
Go to the servo unplug the large hose. Can u blow through it?
Was this
answer
helpful?
Yes
No
Wednesday, July 4th, 2012 AT 8:24 PM
Tiny
SEAN03
  • MEMBER
No I can't
Was this
answer
helpful?
Yes
No
Wednesday, July 4th, 2012 AT 9:29 PM
Tiny
CADIEMAN
  • MEMBER
Ck. The power on the lever connecter for the cruise. If nothing find the lever harness where it comes out the lower column and test it for power.
Was this
answer
helpful?
Yes
No
Wednesday, July 4th, 2012 AT 11:38 PM
Tiny
SEAN03
  • MEMBER
Hey I checked it again the red and blue wire where it plugs in has power. However the green and yellow wire has no power. Here is some pics of what I am testing. Thanks
Was this
answer
helpful?
Yes
No
Thursday, July 5th, 2012 AT 9:26 PM
Tiny
CADIEMAN
  • MEMBER
Lift the front wheels. Turn on the switch on. When u get to 30 mph set the cruise. Ck there is power on the green or yellow wires when u hit the set button. Then ck. And see if the servo seloniod gets power when u set it. If there is power replace the seloniod.
Was this
answer
helpful?
Yes
No
Friday, July 6th, 2012 AT 11:41 PM
Tiny
SEAN03
  • MEMBER
I do this in drive. Also where is the servo seloniod. I can't check the green or yellow wires without disconnecting the clip is their another way to check this. Thanks
Was this
answer
helpful?
Yes
No
Saturday, July 7th, 2012 AT 2:50 PM
Tiny
CADIEMAN
  • MEMBER
The seloniod is on the servo. Youll see a seloniod with a 2 wire connecter and a vacuum line to it. Make sure their is vacuum on that line. Lift the car and when u go over 30 mph. Set the cruise and make sure its sending voltage to the seloniod when u set the cruise.
Was this
answer
helpful?
Yes
No
Saturday, July 7th, 2012 AT 9:27 PM
Tiny
SEAN03
  • MEMBER
Hey I could not find the seloniod on the servo. Here are pictures maybe you can help me. Is the seloniod under the hood or is it inside the car. Would you know where it sits. I have looked all over for it. Thanks for helping so much.
Was this
answer
helpful?
Yes
No
Wednesday, July 11th, 2012 AT 12:11 AM
Tiny
CADIEMAN
  • MEMBER
Im sorry but there to many things and circuts that have to be cked. It makes it hard for me to help anymore.
Was this
answer
helpful?
Yes
No
Wednesday, July 11th, 2012 AT 6:00 AM
Tiny
SEAN03
  • MEMBER
  • 1992 CADILLAC DEVILLE
  • 135,000 MILES
Hi I am looking at a chiltons manuel to diagnose a cruise control problem. I reposted sorry. But Is a speed sensor on the 1992 cadillac deville related to the cruise control. I have checked the fuse it was good. Their is no leak in the vacuum. I changed the cruise lever out. I checked for power it has power. I bought a servo on ebay that was supposobly in working condition. Where is the stepper motor located. From the sounds of it. It is the thing that attaches to the throttle cable and the cruise cable. What is a transducer and how do you test it. Also is their a way to test the cruise servo. Thanks.
Was this
answer
helpful?
Yes
No
Monday, April 27th, 2020 AT 7:36 PM (Merged)
Tiny
KHLOW2008
  • EXPERT
Yes, speed sensors are a vital part of the system as the system needs to keep the vehicle at the speed it was set at.
Transducer should mean the vacuum unit.

What is the problem you are encountering? Are the brake lights working?
Any component or circuits that is not working correctly?
Was this
answer
helpful?
Yes
No
Monday, April 27th, 2020 AT 7:36 PM (Merged)
Tiny
SEAN03
  • MEMBER
Yeah the brake lights work. The problem that I am having is that the cruise control system does not work at all. The light in the display use to glow orange and then when you set it it would glow green. The lights dont glow up at all and when I set the cruise speed it does not set it at all.
Was this
answer
helpful?
Yes
No
Monday, April 27th, 2020 AT 7:36 PM (Merged)
Tiny
KHLOW2008
  • EXPERT
You are moving too far ahead. The indicator light has to show when the cruise control system is turned on. When it does not glow, it can mean either no power supply to it, the switch is bad or you have a missing ground circuit.

Get a DVOM or testlight and pull the switch out. Ensure you have battery voltage at the Brown wire.
Was this
answer
helpful?
Yes
No
Monday, April 27th, 2020 AT 7:36 PM (Merged)
Tiny
SEAN03
  • MEMBER
I have a digital voltmeter. What do I set it to volts dc or ac. What switch do I pull out the turn signal switch that attaches to the collum. It has the cruise switch on it to turn it off and on. Thanks.
Was this
answer
helpful?
Yes
No
Monday, April 27th, 2020 AT 7:36 PM (Merged)
Tiny
KHLOW2008
  • EXPERT
DC with range of up to 20. If you can get at the wiresocket, you need not take out the whole thing.
Was this
answer
helpful?
Yes
No
Monday, April 27th, 2020 AT 7:37 PM (Merged)
Tiny
SEAN03
  • MEMBER
  • 1992 CADILLAC DEVILLE
  • 135,000 MILES
I took my cruise control servo apart. When I lifted the two orange conductors one of them fell apart and I was left with pieces. Do you know how to put it back together. If need be I will take pictures and show you what im talking about. Also does it matter if it doesnt work and I put it back on the car. Does the servo cause the car not to start. Thanks.
Was this
answer
helpful?
Yes
No
Monday, April 27th, 2020 AT 7:37 PM (Merged)
Tiny
ASEMASTER6371
  • EXPERT
No, it does not cause the car not to start. You can leave it off as you most likely need to replace it now.

Send me a picture and I will see what I can tell you

Roy
Was this
answer
helpful?
Yes
No
Monday, April 27th, 2020 AT 7:37 PM (Merged)
Tiny
SEAN03
  • MEMBER
Ok so I was looking for the brown wire but could not find it. Here are some pictures maybe I am looking in the wrong place.
Was this
answer
helpful?
Yes
No
Monday, April 27th, 2020 AT 7:37 PM (Merged)
Tiny
KHLOW2008
  • EXPERT
Wire colors seems to be different from the schematic in our database.

There are 4 wires, ensure at least one of it has battery voltage when ignition is turned on.
Was this
answer
helpful?
Yes
No
Monday, April 27th, 2020 AT 7:37 PM (Merged)
Tiny
SEAN03
  • MEMBER
Hey sorry I havent gotten back to you. I had a few things come up. I will check this tomorrow. I have a lot of spare time on my hands tomorrow. I will let you know once I test this. Thanks.
Was this
answer
helpful?
Yes
No
Monday, April 27th, 2020 AT 7:37 PM (Merged)

Please login or register to post a reply.

Sponsored links