CRUISE CONTROL

  • Tiny
  • Sean03
  • 1992 CADILLAC DEVILLE
  • 135,000 MILES

On my 1992 Cadillac deville. Me and my neighbor tried to pull a vacuum on the cruise control servo. The reason we did this is because the cruise control light won't come on or work. When we pulled the vacuum on it it read 0. We thought that was strange. We took the hose off the servo and I held my finger on the hole. It pulled the vacuum. Would the servo cause the cruise control not to work. Thanks.

Do you
have the same problem?
Yes
No
Wednesday, May 16th, 2012 AT 6:47 PM

30 Replies

  • Tiny
  • Rasmataz
  • MEMBER

Go to this link for more information: http://www.ehow.com/how_4457570_repair-cruise-control-system.html

Was this
answer
helpful?
Yes
No
Wednesday, May 16th, 2012 AT 6:54 PM
  • Tiny
  • Sean03
  • MEMBER

Ok thanks that helped a hole lot. Thank you.

Was this
answer
helpful?
Yes
No
Wednesday, May 16th, 2012 AT 7:06 PM
  • Tiny
  • Cadieman
  • MEMBER

Are u good sean03

Was this
answer
helpful?
Yes
No
Thursday, May 17th, 2012 AT 8:52 PM
  • Tiny
  • Sean03
  • MEMBER

What do you mean. If you are talking about the link than yeah. Thank you.

Was this
answer
helpful?
Yes
No
Thursday, May 17th, 2012 AT 9:01 PM
  • Tiny
  • Cadieman
  • MEMBER

Did u fix it.

Was this
answer
helpful?
Yes
No
Friday, May 18th, 2012 AT 6:19 PM
  • Tiny
  • Sean03
  • MEMBER

No still working on it.

Was this
answer
helpful?
Yes
No
Friday, May 18th, 2012 AT 6:20 PM
  • Tiny
  • Cadieman
  • MEMBER

Does the yellow light come on then turn green when u engage?

Was this
answer
helpful?
Yes
No
Friday, May 18th, 2012 AT 7:14 PM
  • Tiny
  • Cadieman
  • MEMBER

Try lifting the brake pedal with your foot. Will it engage then?

Was this
answer
helpful?
Yes
No
Friday, May 18th, 2012 AT 7:50 PM
  • Tiny
  • Sean03
  • MEMBER

No It doesn't. The light doesn't come on at all. I replaced the turn signal lever and it did not work. I looked at all the wiring didn't see anything wrong. A long time ago when it worked. The car radiator got overheated. We went to a gas station and the had the water hose. My dad turned the engine off and let it sit for 10 to 15 minutes. When he opened the hood and took the cap off it blew up in his face. He had 3rd degree burns. Ever since then it hasn't worked. Any idea. Thanks.

Was this
answer
helpful?
Yes
No
Friday, May 18th, 2012 AT 7:59 PM
  • Tiny
  • Cadieman
  • MEMBER

Remove the lever connector ck for power on the pins where it plugs in. Do u have power?

Was this
answer
helpful?
Yes
No
Friday, May 18th, 2012 AT 11:02 PM

Please login or register to post a reply.

Other Cruise Control Not Working Questions