When accelerating from a stop the car jerks, slow to accelerate and smoke coming from under the hood and the exhaust

Tiny
EVANSCOURTNEY53
  • MEMBER
  • 2010 NISSAN ALTIMA
  • 2.5L
  • 4 CYL
  • AUTOMATIC
  • 202,350 MILES
I took my car to Pepboys for a tune up, they tell me a lot oil got into the spark plugs shaft, and that the valve cover gasket was cracked. So I replaced the valve cover gaskets and got new spark plugs and now my car is jerks like it doesn't want to drive and slow acceleration as it does that smoke comes out my exhaust pipe and from under the hood. It jerks for a little second and then the car drives normal but it always happens after I come to a complete stop. What could be the problem?
Do you
have the same problem?
Yes
No
Monday, September 28th, 2020 AT 11:53 AM

3 Replies

Tiny
ASEMASTER6371
  • EXPERT
Good afternoon,

Did you do the repairs or the repair shop?

If the plugs are not gapped correctly, it will do this.

https://www.2carpros.com/articles/how-to-change-spark-plugs

Was the oil cleaned out of the wells?

https://www.2carpros.com/articles/engine-surges

Roy
Was this
answer
helpful?
Yes
No
Monday, September 28th, 2020 AT 1:50 PM
Tiny
EVANSCOURTNEY53
  • MEMBER
The repair shop replaced it and I believe they was rushing. I don't think they got all the old oil out of the wells or maybe they put it in wrong. I'm not sure.
Was this
answer
helpful?
Yes
No
Monday, September 28th, 2020 AT 9:00 PM
Tiny
ASEMASTER6371
  • EXPERT
I would return the car to the shop and ask them to check there work.

The spark plugs may not be gapped correctly.

Roy
Was this
answer
helpful?
Yes
No
+1
Tuesday, September 29th, 2020 AT 1:06 AM

Please login or register to post a reply.

Sponsored links