Transmission stuck in high gear

Tiny
THOMAS DUNBAR SR.
  • MEMBER
  • 1999 SATURN SL2
  • 1.9L
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 195,000 MILES
Transmission only has reverse and seems to take off in high gear. We tested solenoids and there all good. We checked fuses under the hood there okay but seems like there is no power to them. We are stumped on what to check or replace next. Could it be a bad PCM? Also seems there is no power at plug that goes to solenoid. Any help would be appreciated.
Do you
have the same problem?
Yes
No
Tuesday, June 7th, 2022 AT 6:43 AM

1 Reply

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

I need to know which fuses are not getting power. There are three primary fuses that power is sent through the ignition switch and then back to the box to other fuses. If you let me know which ones have no power, I should be able to trace them backward for you to locate

I attached pics below for your review. The first pic is the under-hood fuse box. Please copy my pic and circle fuses of concern. Also, I included the power distribution wiring schematics for your review. Note how the power from the battery goes to the fuse box. Then, three primary fuses send power to the ignition switch and are distributed to multiple other fuses in the same fuse box.

Let me know.

Take care,

Joe

See pics below. Note: The wiring schematics were two pages. I had to cut each one in half to make it readable for you. I did overlap them for you to follow.
Was this
answer
helpful?
Yes
No
Tuesday, June 7th, 2022 AT 6:18 PM

Please login or register to post a reply.

Sponsored links