Taillights, high beams and manual headlights not working properly

Tiny
MSDFREE1213
  • MEMBER
  • 1996 CADILLAC DEVILLE
  • V8
  • 2WD
  • AUTOMATIC
  • 160,000 MILES
My tail lights and high beams are not working at all. My headlights will only come on in auto sensor mode and while in drive. Cannot turn on manually. Brake lights, parking lights, turn signals, and hazards are all working.
Do you
have the same problem?
Yes
No
Friday, March 6th, 2020 AT 11:25 AM

1 Reply

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

I need to confirm something. You indicated the tail lights aren't working first, and then indicate the parking and other rear lights are working. Please explain.

Next, I have attached a portion of the wiring schematic relating to the headlamps. First confirm the headlamp fuse itself is good and there is power to it.

If the fuse is good and there is power in and out of the fuse, then I need you to check the two relays I circled in the pic.

Here are a few links you may find helpful when testing:

https://www.2carpros.com/articles/how-a-car-fuse-works

https://www.2carpros.com/articles/how-to-check-a-car-fuse

https://www.2carpros.com/articles/how-to-use-a-test-light-circuit-tester

https://www.2carpros.com/articles/how-to-use-a-voltmeter

https://www.2carpros.com/articles/how-to-check-wiring

https://www.2carpros.com/articles/how-to-check-an-electrical-relay-and-wiring-control-circuit

__________________________

If everything checks good, then I suspect the switch is bad. However, let me know what you find before replacing it.

Take care,
Joe
Was this
answer
helpful?
Yes
No
Saturday, March 7th, 2020 AT 6:43 PM

Please login or register to post a reply.

Sponsored links