My engine has no spark can you help me fix it?

Tiny
H2S
  • MEMBER
  • 2002 HONDA ACCORD
I recently bought this honda with the head gasket burnt, I replaced the entire motor for the exact motor with lower milage and in very good condition. I hooked it up properly, I replaced the main relay, I installed a new distributer, spark plugs, plug wires. When I insert the key and turn it to the on position everything looks normal, when I try to start the engine swings just fine. I have good compression everything looks good except im not getting any spark at the plugs.

Please help im out of ideas!
thank you in advance
H2S
Do you
have the same problem?
Yes
No
Tuesday, January 19th, 2010 AT 12:31 PM

43 Replies

Tiny
F4I_GUY
  • EXPERT
Test your ignition coil and ICM. Both are high failing items on hondas This guide can help us fix it.

https://www.2carpros.com/articles/how-to-test-an-ignition-system

Please run down this guide and report back.
Was this
answer
helpful?
Yes
No
Tuesday, January 19th, 2010 AT 8:36 PM
Tiny
H2S
  • MEMBER
Already did and they passed, I was told I need to recode the car key since I changed the engine. I'm not sure if that will help since the key turns everything else on in the car. Just not getting spark?
Was this
answer
helpful?
Yes
No
+1
Thursday, January 21st, 2010 AT 6:23 AM
Tiny
HT3HMF@GMAIL.COM
  • MEMBER
  • 2000 HONDA ACCORD
  • 3.0L
  • V6
  • 2WD
  • AUTOMATIC
  • 182,000 MILES
I am trying to help out a grandma. Just wanted to know if top dead center/camshaft sensors both a and b no signal codes would result in a complete no spark situation. She has her grand kids living with her, been without a car for nearly a month and had hack mechanics tells her everything from needs a new computer to I do not even remember. After that they stop showing up. I am in the middle of an engine swap on my truck, do not have any tools not over with that project and I just want to at least give her the actual facts of her problem.
Was this
answer
helpful?
Yes
No
Wednesday, January 20th, 2021 AT 12:59 PM (Merged)
Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi and thanks for using 2CarPros. Com.

Based on both sensors being bad, yes the vehicle will not run. If you scan the computer and find a P1362 and P1367, chances are they are the issue for the no start.

To confirm the sensors are bad, back probe the harness to determine if there is a 5 volt signal. If there is, check the sensors for resistance. It should be between 1850 to 2450 Ohms of resistance. If it does not fall within the manufacturer's specs, replace them. I have actually found them often times to have no continuity.

I hope you find this helpful. Let me know if you have other questions.

Take care,
Joe

PS: I attached a picture of sensor location if you need it.
Was this
answer
helpful?
Yes
No
+2
Wednesday, January 20th, 2021 AT 12:59 PM (Merged)
Tiny
GASKIN73
  • MEMBER
  • 1998 HONDA ACCORD
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 170,000 MILES
It is getting fuel, but is not firing. I have replaced the coil and ignition module, but it will still not fire. What else can be the problem?
Was this
answer
helpful?
Yes
No
-1
Wednesday, January 20th, 2021 AT 12:59 PM (Merged)
Tiny
KHLOW2008
  • EXPERT
Hi gaskin73,

Are the dash indicator lights showing when ignition switch is turned to ON and while cranking?

Is voltage available at distributor Black/Yellow wire with ignition switch ON and while cranking?

Was any repairs carried prior to this happening?
Does the Check Engine Light shows for 2 seconds before going off when ignition switch is turned to ON?

This guide should help

https://www.2carpros.com/articles/how-to-test-an-ignition-system

Please run down this guide and report back.
Was this
answer
helpful?
Yes
No
-1
Wednesday, January 20th, 2021 AT 12:59 PM (Merged)
Tiny
GASKIN73
  • MEMBER
Dash indicator lights comes on when car is switched on and when cranking

There is battery voltage at the distributor, Black/yellow wire

No repairs have been made

Check engine light has been on for years, EGR code
Was this
answer
helpful?
Yes
No
Wednesday, January 20th, 2021 AT 12:59 PM (Merged)
Tiny
KHLOW2008
  • EXPERT
When did you last checked the CEL code? It could be the EGR but did you check if there were any new codes?

Are you getting sparks when cranking?
Was this
answer
helpful?
Yes
No
-2
Wednesday, January 20th, 2021 AT 12:59 PM (Merged)
Tiny
ANGELA59
  • MEMBER
  • 1997 HONDA ACCORD
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 179,680 MILES
This car cranks over but there is no spark and no start. We have replaced the distributor, ignition coil and crank shaft position sensor with the same result itwill crank but will not start. Please help Angela
Was this
answer
helpful?
Yes
No
Wednesday, January 20th, 2021 AT 1:00 PM (Merged)
Tiny
RASMATAZ
  • EXPERT
Get a test light and probe the negative side of the coil and crank engine over -is the test light blinking.
Was this
answer
helpful?
Yes
No
+1
Wednesday, January 20th, 2021 AT 1:00 PM (Merged)
Tiny
ANGELA59
  • MEMBER
No the test light does not blink
Was this
answer
helpful?
Yes
No
+1
Wednesday, January 20th, 2021 AT 1:00 PM (Merged)
Tiny
RASMATAZ
  • EXPERT
Do you have battery voltage at coil positive terminal?
Was this
answer
helpful?
Yes
No
+5
Wednesday, January 20th, 2021 AT 1:00 PM (Merged)
Tiny
ANGELA59
  • MEMBER
Yes, but no injection pulse, no fuel pump and no spark
Was this
answer
helpful?
Yes
No
Wednesday, January 20th, 2021 AT 1:00 PM (Merged)
Tiny
RASMATAZ
  • EXPERT
Check and test the PGM-FI main relay then comeback
Was this
answer
helpful?
Yes
No
+1
Wednesday, January 20th, 2021 AT 1:00 PM (Merged)
Tiny
ANGELA59
  • MEMBER
We replaced that too and it clicked but still no start. See the first problem with this car is that someone had taken it upon themselves to decide they were capable of adding alot of electronioc equipment and lots of new wires without taking into consideration what they were shorting out in the process. The only reason we have not given up is because it really is a nice car. But none of it makes sense.
Was this
answer
helpful?
Yes
No
Wednesday, January 20th, 2021 AT 1:00 PM (Merged)
Tiny
RASMATAZ
  • EXPERT
No injection pulses/ignition/fuel -could mean computer
Was this
answer
helpful?
Yes
No
Wednesday, January 20th, 2021 AT 1:00 PM (Merged)
Tiny
ANGELA59
  • MEMBER
Computer is functioning too.
Was this
answer
helpful?
Yes
No
Wednesday, January 20th, 2021 AT 1:00 PM (Merged)
Tiny
RASMATAZ
  • EXPERT
When you turn key to run position -do you hear the fuel pump come On?
Was this
answer
helpful?
Yes
No
-1
Wednesday, January 20th, 2021 AT 1:00 PM (Merged)
Tiny
ANGELA59
  • MEMBER
Well we found the problem. This is really embarassing but when we tested the fuses they tested good. What we failed to do is check for missing fuses. I will be sending my donation and really appriciate your help you have been extremely helpful. The fuel pump fuse was missing in fuse box. The fuse diagram was missing. On this car unfortunately it powers the EFI relay that powers the computer.

Angela
Was this
answer
helpful?
Yes
No
+1
Wednesday, January 20th, 2021 AT 1:00 PM (Merged)
Tiny
TYLER ROY
  • MEMBER
  • 1997 HONDA ACCORD
  • 2.2L
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 92,000 MILES
I have weak spark coming out of plug wires, tested coil wire it throws a big blue spark. I replaced plug wires, distributor, coil, main relay and still weak spark out of plug wires, checked all grounds- all good! Sometimes I go to crank it up and it fires off right away, go to restart it and back to weak spark! Any clue?
Was this
answer
helpful?
Yes
No
Wednesday, January 20th, 2021 AT 1:00 PM (Merged)

Please login or register to post a reply.

Sponsored links