Driver side taillight not working

Tiny
2020BWOLFE
  • MEMBER
  • 2011 CHEVROLET 1500
  • 4.8L
  • V8
  • 4WD
  • AUTOMATIC
  • 118,000 MILES
It has blinkers and brake lights but no running lights, so I cannot drive at night. I’ve checked the fuses, I couldn’t find and that were blown. I’ve taken each connection out of the circuit board under the tailgate and cleaned it thoroughly (no corrosion there to start with). I have license plate lights and my passenger side works great, just my driver side running light does not work.
Do you
have the same problem?
Yes
No
Tuesday, March 3rd, 2020 AT 2:15 PM

3 Replies

Tiny
JOE F
  • EXPERT
Hi,

First, have you checked to see if there is power to the light related to the driving lights? Is the left license plate light working? If you look at the attached pic (pic 2), it shows a brown wire that runs to the junction block I believe you checked. You need to make sure there is power to that wire. Next, there is a separate fuse and relay for the left parking light. See pic 1. Check that as well as the relay. The last pic I attached shows the light socket. Since other lights are working, I suspect it is between the junction and the lamp.

Here are a few links you may find helpful:

https://www.2carpros.com/articles/how-a-car-fuse-works

https://www.2carpros.com/articles/how-to-check-a-car-fuse

https://www.2carpros.com/articles/how-to-use-a-voltmeter

https://www.2carpros.com/articles/how-to-use-a-test-light-circuit-tester

https://www.2carpros.com/articles/how-to-check-wiring

https://www.2carpros.com/articles/how-to-check-an-electrical-relay-and-wiring-control-circuit

___________________________________

Let me know what you find.

Take care,
Joe
Was this
answer
helpful?
Yes
No
+1
Tuesday, March 3rd, 2020 AT 6:24 PM
Tiny
2020BWOLFE
  • MEMBER
Appreciate the response. I had an extra harness lying around so I cut the plugs off of my taillight and harness and spliced the new plug on and seemed to have fixed my issue. Not very knowledgeable with all the correct names but I figured it out. Once again, thanks.
Was this
answer
helpful?
Yes
No
Tuesday, March 3rd, 2020 AT 6:30 PM
Tiny
JOE F
  • EXPERT
You are very welcome. I'm glad you got it fixed. It sounds like the break was somewhere in that harness.

Take care and feel free to come back in the future.

Joe
Was this
answer
helpful?
Yes
No
+1
Tuesday, March 3rd, 2020 AT 7:16 PM

Please login or register to post a reply.

Sponsored links