Engine stops pulling and acts like it is going to shut off until RPMs drop

Tiny
TAMMY L. NIEMAN
  • MEMBER
  • 2003 FORD EXPEDITION
  • 4.6L
  • V8
  • 2WD
  • AUTOMATIC
  • 80,000 MILES
High RPMs, low MPH. Stops pulling and acts like it's going to shut off until RPMs drop. When speedometer hits 105 it acts like it's going to shut off and stops pulling. Speed is actually around 20 to 25 MPH. Changed transmission speed sensor and no change. Been without a ride since December 1, 2020. Desperately need to get this figured out. I am disabled and have no other means of transportation. Also temperature gauge is reading below cold constantly does not change. Have not pulled codes yet. Also just replaced the transmission with a used one.
Do you
have the same problem?
Yes
No
Saturday, March 27th, 2021 AT 3:57 AM

2 Replies

Tiny
ASEMASTER6371
  • EXPERT
Good morning,

Have you changed the fluid and filter? A clogged filter will cause this issue.

https://www.2carpros.com/articles/automatic-transmission-problems

https://www.2carpros.com/articles/how-to-service-an-automatic-transmission

I would start there and see if there is any debris in the pan.

Roy
Was this
answer
helpful?
Yes
No
Saturday, March 27th, 2021 AT 4:12 AM
Tiny
ASEMASTER6371
  • EXPERT
This could also be an axle shaft failing not providing power to the wheels for the car to move.

I attached guides and the procedure below.

https://www.2carpros.com/articles/how-a-cv-joint-works

https://www.2carpros.com/articles/replace-cv-axle

Roy
Was this
answer
helpful?
Yes
No
Tuesday, March 30th, 2021 AT 12:43 PM

Please login or register to post a reply.

Sponsored links