Car reving high in idle the goes to nothing

Tiny
ADAMFASCA
  • MEMBER
  • 1997 CHEVROLET CAMARO
  • 3.8L
  • V6
  • 2WD
  • AUTOMATIC
  • 145,000 MILES
Car revs in idle to 2 rpm then goes to 3 rpm or goes to below 1 rpm.
Do you
have the same problem?
Yes
No
Monday, April 15th, 2019 AT 4:57 AM

25 Replies

Tiny
ASEMASTER6371
  • EXPERT
Good morning,

I would suspect a vacuum leak that is causing the idle to not act correctly.

https://www.2carpros.com/articles/engine-idles-too-high

Inspect all the hoses for cracks or breaks.

Also, there is an idle air control motor that does regulate the idle speed. Check the connection as well.

https://www.2carpros.com/articles/how-to-replace-an-idle-speed-control-motor-iac

Are there any codes set?

Roy

Was this
answer
helpful?
Yes
No
Monday, April 15th, 2019 AT 5:19 AM
Tiny
ADAMFASCA
  • MEMBER
I changed the valve and no leaks. My battery is now dead from checking it and checking the idling. It still revs up and then back down then up then goes until now battery dead.
Was this
answer
helpful?
Yes
No
Monday, April 15th, 2019 AT 2:35 PM
Tiny
ASEMASTER6371
  • EXPERT
Charge the battery back up.

Was any work done prior to this issue?

Roy
Was this
answer
helpful?
Yes
No
Monday, April 15th, 2019 AT 3:17 PM
Tiny
ADAMFASCA
  • MEMBER
Could this be a alternator issue? Battery only a year old and was told it is bad.
Was this
answer
helpful?
Yes
No
Monday, April 15th, 2019 AT 6:54 PM
Tiny
ASEMASTER6371
  • EXPERT
It could be for the battery going dead, yes, but not the high idle issue.

https://www.2carpros.com/articles/car-battery-load-test

https://www.2carpros.com/articles/how-to-check-a-car-alternator

Roy
Was this
answer
helpful?
Yes
No
Monday, April 15th, 2019 AT 7:00 PM
Tiny
ADAMFASCA
  • MEMBER
Before the car did the high idle I added a purge valve added a line to the intake. I ve now put everything back as is but still high idles and then goes all the way down on RPM's and the battery voltages is erratic and goes in red.
Was this
answer
helpful?
Yes
No
Monday, April 15th, 2019 AT 7:06 PM
Tiny
ASEMASTER6371
  • EXPERT
What voltages? What are the exact voltages?

You may have a bad idle air control valve in the throttle body.

Roy
Was this
answer
helpful?
Yes
No
Monday, April 15th, 2019 AT 7:12 PM
Tiny
ADAMFASCA
  • MEMBER
Mine was on top and I replaced today brand new and same issue. I do have a code for the TPS now would that cause this issue?
Was this
answer
helpful?
Yes
No
Monday, April 15th, 2019 AT 7:27 PM
Tiny
ASEMASTER6371
  • EXPERT
If is not adjusted correctly yes.

Roy
Was this
answer
helpful?
Yes
No
Monday, April 15th, 2019 AT 7:35 PM
Tiny
ADAMFASCA
  • MEMBER
If I buy a new one does it have to be adjusted?
Was this
answer
helpful?
Yes
No
Tuesday, April 16th, 2019 AT 4:43 AM
Tiny
ASEMASTER6371
  • EXPERT
Generally, no.

It just bolts on to the throttle body and there are no provisions for adjusting.

Roy

Procedure

REMOVE OR DISCONNECT
1. The Throttle Position (TP) sensor electrical connector.
2. The two TP sensor attaching screws.

INSTALL OR CONNECT
1. With the throttle valve in the normal closed idle position, install the TP sensor on the throttle body assembly, making sure the TP sensor pickup lever is located above the tang on the throttle actuator lever.
2. The two TP sensor attaching screws, using a thread-locking compound on the screws. Loctite 262, GM Part No. 1052624, or equivalent should be used.
3. The TP sensor electrical connector.
Was this
answer
helpful?
Yes
No
+1
Tuesday, April 16th, 2019 AT 4:57 AM
Tiny
ADAMFASCA
  • MEMBER
It ended up being the MAF sensor. The car rides smooth once driven but in the beginning it starts to shake for a little until driven a little. I can hear a vacuum leak just can t find. Also the car revs when put into drive and reverse. Could it be from the leak? Thanks
Was this
answer
helpful?
Yes
No
Tuesday, April 16th, 2019 AT 8:23 PM
Tiny
ASEMASTER6371
  • EXPERT
No. The leak has no effect on the roving.

Roy
Was this
answer
helpful?
Yes
No
Tuesday, April 16th, 2019 AT 11:57 PM
Tiny
ADAMFASCA
  • MEMBER
I have to play with the battery terminals in order to get it to run. I have to put the car on "on" and rotate the positive cable around all over the place for it to even get a connection. Is it bad cables or the terminal itself I can t see the wires because it s in a housing. Sometimes the car will start and others makes the battery tick noise if it s not at right angle I assume.
Was this
answer
helpful?
Yes
No
Wednesday, April 17th, 2019 AT 3:54 AM
Tiny
ASEMASTER6371
  • EXPERT
You either need to replace the entire cable or clean the cables real good.

https://www.2carpros.com/articles/everything-goes-dead-when-engine-is-cranked

Roy
Was this
answer
helpful?
Yes
No
+1
Wednesday, April 17th, 2019 AT 3:57 AM
Tiny
ADAMFASCA
  • MEMBER
1. Cable cleaning worked and I can start the car right away it now just sputters In beginning until I drive for about thirty seconds not sure if it will shut off if I didn t move it.
2. There must be a leak but when I press the gas pedal it pretty much goes away and I hear nothing but the moment I let go it s back. Where could this possible be?
Thanks for all the help.
Was this
answer
helpful?
Yes
No
Wednesday, April 17th, 2019 AT 4:20 PM
Tiny
ASEMASTER6371
  • EXPERT
Goes away? Please explain.

Roy
Was this
answer
helpful?
Yes
No
Wednesday, April 17th, 2019 AT 4:27 PM
Tiny
ADAMFASCA
  • MEMBER
When I press the gas pedal the sound goes away or it lessens drastically, but the moment my foot comes off it makes a scream like sound not to loud but noticeable or vacuum sound.
Was this
answer
helpful?
Yes
No
Wednesday, April 17th, 2019 AT 4:35 PM
Tiny
ASEMASTER6371
  • EXPERT
Got it.

You have a vacuum leak somewhere. You need to find where that squealing is coming from.

Spray some starting fluid around some areas it sounds like where it is coming from. It will stop when you get to the area.

Roy
Was this
answer
helpful?
Yes
No
Wednesday, April 17th, 2019 AT 4:38 PM
Tiny
ADAMFASCA
  • MEMBER
I sprayed the EGR and the engine sounds quieter and smoother. I almost sprayed too much and it was slowing down the engine. Is the EGR sucking in air?
Was this
answer
helpful?
Yes
No
Thursday, April 18th, 2019 AT 2:08 PM

Please login or register to post a reply.

Recommended Guides