Brake lights not working

Tiny
KYARBOUGH
  • MEMBER
  • 2005 CADILLAC CTS
Electrical problem 6 cyl Two Wheel Drive Automatic 40K miles

2005 Cadillac CTS, left & right brake lights don't work. Center light does. Bulbs and fuses check out OK, what else could be the problem? The turn signal lights are actually the yellow light below the red section of the tail lamp. They work just fine. When the driving lights are on the tail lamps light one of the two filaments. The 3rd light also works. Any other thoughts?

Thanks,
Kevin
Do you
have the same problem?
Yes
No
Monday, September 29th, 2008 AT 1:58 PM

19 Replies

Tiny
JACK42
  • MEMBER
It looks like the brake lights go through the ABS controller here is the wiring diagram so you can look how the system works.

Here is a guide to help you see where you are loosing power start at the switch.

https://www.2carpros.com/articles/how-to-use-a-test-light-circuit-tester

Check out the diagrams (Below)

Please let us know what you find. We are interested to see what it is.

Cheers
Was this
answer
helpful?
Yes
No
+1
Monday, September 29th, 2008 AT 4:10 PM
Tiny
KYARBOUGH
  • MEMBER
With the car started and the driving lights on, there is no power to the white wires that enter the light sockets.
Was this
answer
helpful?
Yes
No
Monday, September 29th, 2008 AT 4:22 PM
Tiny
JACK42
  • MEMBER
Need to check with someone pressing on brake pedal. It sounds like the module is bad here is a guide to help you see what you are in for when doing the job.

https://www.2carpros.com/articles/how-to-replace-a-abs-controller

Please let us know what happens.

Cheers
Was this
answer
helpful?
Yes
No
+1
Monday, September 29th, 2008 AT 4:40 PM
Tiny
KYARBOUGH
  • MEMBER
Yep that was it I found the power was going in but not coming out. I got the part on Amazon for $149.99 put it on myself. Thanks for the tip I love this site.
Was this
answer
helpful?
Yes
No
+1
Monday, September 29th, 2008 AT 4:44 PM
Tiny
GMALIBU004
  • MEMBER
I have the exact same problem. Both Lights are out, but third light works? No power to the white wires did the module all good.

Many thanks
Was this
answer
helpful?
Yes
No
+1
Wednesday, May 6th, 2009 AT 8:06 PM
Tiny
FACTORYJACK
  • EXPERT
Replace the bulbs, uppermost bulb in each lamp assembly. I believe the service # is 3057. Remove the trunk opening sill plate, pull away the side trim panels to access the 10mm nuts(2). Odds are that one was out, and eventually the other went.
Was this
answer
helpful?
Yes
No
Wednesday, May 6th, 2009 AT 9:45 PM
Tiny
FACTORYJACK
  • EXPERT
THB, is your high mount working as well? Looking at my schematic from GM service information, the white wire comes from the BAS relay and hits a splice pack(or joint connector), that is part of the rear LH fuse block under the seat cushion. From this joint connector, the three powers for the lights exit. The only possible way that both rear bulbs don't brake, but the high mount does, is if there is a fault with that joint connector, C410 for left light AND C411 right both pins b, or the individual right and left sockets. The left and high mount share ground G402, and the right uses G401. If nothing works, then yes, it could be the BCM.
Was this
answer
helpful?
Yes
No
+2
Wednesday, June 24th, 2009 AT 10:13 PM
Tiny
RONINSEC
  • MEMBER
How would I test this joint connector and where are these pins on the connector located for the test
Was this
answer
helpful?
Yes
No
Wednesday, November 4th, 2009 AT 5:44 PM
Tiny
MATTMEHAFF
  • MEMBER
Okay I just had the same problem with my 2005 CTS. Side break lights not working but center brake light works good. Did a bunch of troubleshooting changed bulbs, checked fuses, checked relays. Ended up realizing there's actually 5 brake lights! Two in each back light & the one center. The first bulbs that I had changed were the center bulbs in each side tail light. They looked great but I changed them anyways. Tonight I went to change the top bulbs in each side tail lights and they both were fried. Changed them out with 3157 bulbs and everythings working good. I did notice that the bulbs I pulled out were 3057 not 3157 which is what they should've been. I'm guessing this is a factory error since I've seen about 5 other Cadillac CTS around the same year as mine with there side brake lights out and middle light good. Hopefully this helps. Long story short buy 4- 3157 bulbs and replace both top and center bulbs in each brake light compartment. Worked for me
Was this
answer
helpful?
Yes
No
+2
Wednesday, August 17th, 2016 AT 1:09 AM
Tiny
KEN
  • ADMIN
Hey,

Great addition to this thread! Please feel free to help out on the site whenever it can add information that will help people.

Best, Ken
Was this
answer
helpful?
Yes
No
Monday, February 27th, 2017 AT 10:56 AM
Tiny
FRANKGUERRERO
  • MEMBER
  • 2005 CADILLAC CTS
Electrical problem
2005 Cadillac CTS 6 cyl Two Wheel Drive Automatic 150k miles

My brake lights are not working, everybody else's questions like this one say their third brake light works. Mine does not, both corner lights and third (top) brake light do not work. Bulbs turn red when the lights are on, but they don't flash when i press the brakes. what could be the problem?


http://www.2carpros.com/forum/automotive_pictures/582144_DSC01048_1.jpg

Was this
answer
helpful?
Yes
No
+2
Monday, February 27th, 2017 AT 10:56 AM (Merged)
Tiny
RASMATAZ
  • MEMBER
Check the brake switch
Was this
answer
helpful?
Yes
No
+1
Monday, February 27th, 2017 AT 10:56 AM (Merged)
Tiny
FRANKGUERRERO
  • MEMBER
What if I can not find the brake switch? Do you know where its located exactly?
Was this
answer
helpful?
Yes
No
+1
Monday, February 27th, 2017 AT 10:56 AM (Merged)
Tiny
RASMATAZ
  • MEMBER
Follow the brake pedal arm till it meets up to the brake support bracket you'll find it here
Was this
answer
helpful?
Yes
No
+2
Monday, February 27th, 2017 AT 10:56 AM (Merged)
Tiny
ROBERT MOALES
  • MEMBER
  • 2005 CADILLAC CTS
Electrical problem
2005 Cadillac CTS V8 Two Wheel Drive Automatic

brakes lights not working all other lights work all fuses are good brake switch changed figured it must be a lighting problem
Was this
answer
helpful?
Yes
No
+1
Monday, February 27th, 2017 AT 10:57 AM (Merged)
Tiny
DOCFIXIT
  • EXPERT
Probably faulty Electronic Brake Control Module at right front corner of engine compartment
Was this
answer
helpful?
Yes
No
Monday, February 27th, 2017 AT 10:57 AM (Merged)
Tiny
FACTORYJACK
  • EXPERT
Are all brake lamps inoperative, does the high mount lamp illuminate. This would confirm that the switch circuitry is functional. If the high mount functions, I would replace bulbs first, before going any further.
Was this
answer
helpful?
Yes
No
Monday, February 27th, 2017 AT 10:57 AM (Merged)
Tiny
STEVEM147
  • MEMBER
  • 2005 CADILLAC CTS
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 48,000 MILES
Electrical problem
2005 Cadillac CTS 6 cyl Two Wheel Drive Automatic 48000 miles

Rear brake lights are not working. The middle brake light across the trunk is still working.
Was this
answer
helpful?
Yes
No
Monday, February 27th, 2017 AT 10:57 AM (Merged)
Tiny
FACTORYJACK
  • EXPERT
Since the high mount works, that verifies at least the switch is functioning. I would try a bulb in at least one side, see if that corrects it. If so, replace the other one.
Was this
answer
helpful?
Yes
No
Monday, February 27th, 2017 AT 10:57 AM (Merged)

Please login or register to post a reply.

Recommended Guides