ENGINE PERFORMANCE PROBLEM1986 BMW 325 6 CYL ...

1986 BMW 325

Tiny

socaljeep

July, 12, 2008 AT 9:47 AM

Engine Performance problem
1986 BMW 325 6 cyl Two Wheel Drive Manual 168 miles

My 1986 325 blows black smoke and wont run at low RPM's, but does not act this way all the time. It at times will run fine and them start running rough and blow black smoke. The engine doesnt burn a drop of oil. What do you think?

Thanks

FOUND 740 RELATED QUESTIONS

Black Smoke Coming From Exhaust

65 ANSWERS
100 IMAGES

Smoking

32 ANSWERS
48 IMAGES

6 Answers

Tiny

Dr. Hagerty

July, 12, 2008 AT 1:10 PM

The air flow meter is at the heart of how much fuel is injected and it might require replacement. You did not mention any history of the service and I usually try to get as much information as possible before making any recommendations.

Tiny

socaljeep

July, 12, 2008 AT 1:47 PM

Thank you for your reply. I think I have solved the problem but would like to know your opinion. The rubber air hose that connects from the air box to a plastic fitting next to the fan/shroud had become disconnected. I reattached the larger (4-5" ) rubber hose to the plastic fitting so the sensor is not getting hot engine compartment air. I believe with the hose not properly attached, the air box was pulling in the higher temp engine compartment air and adjusting the mixture accordingly. Do you believe I am correct? The car is running fine now! Should I continue to investigate? A little history on the maintnance, I had kept the car properly maintained wiith 168K miles. The care does not burn a drop of oil and is mechanically sound. Thanks for your reply.

Joel: alaskaflyfishing@verizon. Net

Tiny

Dr. Hagerty

July, 12, 2008 AT 4:18 PM

Sounds like you fixed it mate, good on ya!

Tiny

socaljeep

July, 12, 2008 AT 6:47 PM

Thanks for your help Doc!

Tiny

socaljeep

July, 14, 2008 AT 2:57 PM

I have another question for you if you dont mind. The " factory" cruise control in the 1986 325 has stopped working. Do you have any suggestions?

Thanks again for your input!

Joel

Tiny

Dr. Hagerty

July, 14, 2008 AT 9:02 PM

It might be several things that can keep the cruise control from functioning properly. It could be a broken trace on the circuit board in the instrument cluster or even a blown fuse. It can be a broken servo cable or no tempo input from the instrument cluster. If the cruise control is that important to you I recommend seeking out local professional help.

Please login or register to post a reply.

Replace Fuel Pressure Regulator
Fuel Injector Replacement Ford 5.4L V8
Valve Cover Gasket Replacement Toyota Corolla