Truck cranks but wont start

Tiny
JRILE009
  • MEMBER
  • 2005 CHEVROLET SILVERADO
  • 6 CYL
  • 2WD
  • MANUAL
  • 51,000 MILES
I have a 2005 Chevy Silverado 1500 2 wheel drive 4.3L V6. I recently replaced the fuel pump because the truck would not start. Replacing the pump fixed the problem, but now its doing the same two mouths later. Cranks but will not start. Yesterday I left for work the truck started and ran for about four miles and then it just quit. No noises, no smoke nothing. I checked all the fuses and attached a test light to one of the plugs. No fire. Attached a code scanner to the truck and it will not even power up. I tried the scanner on another vehicle and it worked fine. I pulled a plug, lots of gas on it. Any ideas? Any help would be greatly appreciated.
Do you
have the same problem?
Yes
No
Tuesday, April 26th, 2011 AT 5:24 AM

4 Replies

Tiny
KEN
  • ADMIN
Hello,

It sounds like you have a crankshaft angle sensor that is not working right. We just had one of these trucks in the shop with the same problem. After testing we found the crankshaft sensor to be bad and once we replaced it everything came back to life. you will need to have the sensor programmed in at a shop which runs about $80.00

Here is a guide to help you see what you are in for when doing the job.

https://www.2carpros.com/articles/crankshaft-angle-sensor-replacement

This guide can help as well

http://www.2carpros.com/articles/car-cranks-but-wont-start

Please run some tests and get back to us so we can continue helping you.

Let us know what happens and please upload pictures or videos of the problem.

Cheers, Ken

Was this
answer
helpful?
Yes
No
Tuesday, April 26th, 2011 AT 10:42 AM
Tiny
SMASHMAN
  • MEMBER
  • 2003 CHEVROLET SILVERADO
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 104,310 MILES
Engine Performance problem
2003 Chevy Silverado 6 cyl Two Wheel Drive Automatic 104310 miles

I have a 2003 chevy silverado. Tried to crank up my truck after letting it sit a week and it would not start. So I tried to jump it off and it would not start. Then I replaced the crankshaft sensor and it ran great for 5 mouths now all of the sudden the security light comes on to when I try to start it?
Was this
answer
helpful?
Yes
No
+1
Wednesday, December 14th, 2016 AT 10:14 AM (Merged)
Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi:

If the security light is flashing and it hasn't in the past, there is a problem in the security system. The system basically recognizes a code from the key through the steering column. If you have a spare key, try that. If it doesn't work, I recommend going to this link

https://www.2carpros.com/articles/how-to-reset-a-security-system

Let me know how it goes.

Joe
Was this
answer
helpful?
Yes
No
+1
Wednesday, December 14th, 2016 AT 10:14 AM (Merged)
Tiny
SMASHMAN
  • MEMBER
Took it to the dealership and it was a fuel pump relay. Got it fixed. Wanted others to know.
Was this
answer
helpful?
Yes
No
+2
Wednesday, December 14th, 2016 AT 10:14 AM (Merged)

Please login or register to post a reply.

Recommended Guides