I JUST REPLACED BOTH TIMING BELTS AND ...

2003 Kia Optima

Tiny

Bam24sho

December, 29, 2012 AT 6:35 AM

I just replaced both timing belts and cranksensor on my way 2003 Kia optima 2.4 car ran awesome for 2 weeks then on way to work car just lost all power and runs rough now won't rev past 2000rpms? (HELP)

FOUND 2255 RELATED QUESTIONS

5 Answers

Tiny

KHLow2008

December, 29, 2012 AT 12:03 PM

Is the Malfunction Indicator Light showing?
Have you checked the spark plugs and related components? Something might have come loose.

Tiny

Bam24sho

December, 30, 2012 AT 1:09 AM

No it will barely start when it does it idles very rough and u can give it any gas or it stalls I already replaced fuel pump and strainer I have heard crank sensor?

Tiny

KHLow2008

December, 30, 2012 AT 7:52 AM

Did you check for trouble codes?
If you keep guessing what could be the problem, you are going for a long and rough ride which could be costly as well.
.

Tiny

Bam24sho

December, 30, 2012 AT 5:47 PM

Yes but no codes.I'm stumped

Tiny

KHLow2008

December, 30, 2012 AT 6:02 PM

Recheck the cranksensor wires. When routing them, there are times whereby they gets too close to belts and other moving parts and this can result in the wires getting damaged.

Did the MIL indicate at any time when the problem occurred?
Was the fuel pressure checked?

Please login or register to post a reply.

Step by Step Timing Belt Replacement Guide
Serpentine Belt Replacement Ford Contour
Serpentine Belt Replacement Acura MDX
Serpentine Belt Replacement Chevy 1500
Serpentine Belt Replacement Chevrolet
Serpentine Belt Replacement Saturn Vue
Serpentine Belt Replacement Mercedes Benz
Serpentine Belt Replacement Chrysler