Won't shift out of first gear and just revs like it is in neutral

Tiny
PHSCHICK91
  • MEMBER
  • 2002 JEEP CHEROKEE
  • 90,000 MILES
I go to take off in my jeep and can't even go 20 mph and it acts like it is in neutral and just revs up. If I turn if off and take off the battery terminals it will run fine
Do you
have the same problem?
Yes
No
Friday, September 9th, 2011 AT 10:02 PM

7 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
This sounds like a computer related issue. Have you scanned the computer to determine if there are any trouble codes related to the transmission? Have any warning lights come on? Is the fluid full and clean?
Was this
answer
helpful?
Yes
No
Friday, September 9th, 2011 AT 10:21 PM
Tiny
PHSCHICK91
  • MEMBER
Transmission fluid is good. I have not hooked it up to a computer. Where would I go to do that?
Was this
answer
helpful?
Yes
No
Friday, September 9th, 2011 AT 10:26 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
I would like to say most parts stores will do it for free; however, they usually only have basic scanners that read engine codes only. You will most likely need to see a regular shop. You could call nationally recognized parts stores to see if they can do it. Please keep in mind, this could be other things too. There could be an issue with a shift solenoid, the governor, a clutch pack. The scan should identify if it is related to any of the electrical components that run the transmission. (I miss the old hydraulicly run transmissions. They were much easier to diagnose!)
Was this
answer
helpful?
Yes
No
Friday, September 9th, 2011 AT 10:33 PM
Tiny
PHSCHICK91
  • MEMBER
I took it to an auto shop and they reset something and said that should of helped it but it didn't
Was this
answer
helpful?
Yes
No
Friday, September 9th, 2011 AT 10:41 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Do you remember what it was? Did they provide any information that could be helpful for me?
Was this
answer
helpful?
Yes
No
Friday, September 9th, 2011 AT 10:44 PM
Tiny
PHSCHICK91
  • MEMBER
I can't remember what they called it. I think it was a sensor
Was this
answer
helpful?
Yes
No
Friday, September 9th, 2011 AT 10:50 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
That is what I was thinking, something electric. It could be a bad shift solenoid.
Was this
answer
helpful?
Yes
No
Saturday, September 10th, 2011 AT 12:37 AM

Please login or register to post a reply.

Recommended Guides