After replacing the stereo vehicle shuts off while driving

Tiny
TIARARICH46917
  • MEMBER
  • 2003 CHEVROLET SUBURBAN
  • 5.3L
  • V8
  • 4WD
  • AUTOMATIC
  • 189,000 MILES
I switched my stereo to my Denali and it locked stereo up switched it back to my suburban turned on no problem. Now my suburban will just shut off no reason driving down the road and sometimes it won’t start at all.
Do you
have the same problem?
Yes
No
Wednesday, March 31st, 2021 AT 10:23 PM

3 Replies

Tiny
KEN
  • ADMIN
This sounds like the crankshaft angle sensor or the fuel pump has gone out. when you turn the key to the on position without cranking the engine over can you hear the fuel pump run in the tank for 5 seconds? These guides should help us fix it.

https://youtu.be/dCjmRL3p4Cs

and

https://www.2carpros.com/articles/car-cranks-but-wont-start

Also, lets run the codes to see what come up.

https://www.2carpros.com/articles/checking-a-service-engine-soon-or-check-engine-light-on-or-flashing

Please run down these guides and report back.
Was this
answer
helpful?
Yes
No
Saturday, April 3rd, 2021 AT 11:06 AM
Tiny
TIARARICH46917
  • MEMBER
Yes, you can hear fuel pump kick on that was replaced not to long ago. Not throwing any codes. It did start up run for 45 minutes then shut off. Haven't checked crankshaft sensor. Did reprogram key fob. So will let you know.
Was this
answer
helpful?
Yes
No
Sunday, April 4th, 2021 AT 2:25 AM
Tiny
KEN
  • ADMIN
Please let us know what you find. We are interested to see what it is.
Was this
answer
helpful?
Yes
No
Sunday, April 4th, 2021 AT 9:39 AM

Please login or register to post a reply.

Sponsored links