Rear turn signal is not working

Tiny
DDAVIS15
  • MEMBER
  • 2005 CHEVROLET IMPALA
  • 3.4L
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 250,000 MILES
The bulb is shining but it doesn't blink when I signal to make a right turn. The flasher on the dash is blinking fast. How do I solve this problem?
Do you
have the same problem?
Yes
No
Tuesday, January 28th, 2020 AT 2:11 PM

1 Reply

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

If the flasher is flashing double time, that indicates a bulb has failed. Now, first turn the signal on. When it is flashing quickly inside, check both front and rear of the vehicle. One of them should be flashing fast and the other doing nothing.

So, I suspect either you missed the front one isn't working, or the rear bulb needs replaced. The rear signal bulb has two elements in it. One is lit with the parking lights and the other lights with turn signals or the brake light. Have a helper check to see if both brake lights are working. If the front bulb is flashing, I suspect one of the elements in the bulb is bad and the other still working.

I attached a picture below. It shows a pic of the bulb circuit. Note that I circled two elements on the right. Those are two separate bulbs that are both parking lights. The arrow is pointing to the element for the signal and brake light. So, have a helper check if both brake lights work. If they do, then the problem is most likely at the front.

__________________________

Here is a link you may find helpful:

https://www.2carpros.com/articles/turn-signal-bulb-replacement

Let me know if this helps. Please feel free to let me know if you have questions.

Take care,
Joe

Was this
answer
helpful?
Yes
No
Tuesday, January 28th, 2020 AT 6:57 PM

Please login or register to post a reply.

Sponsored links