Hesitates, shakes and back fires

Tiny
WILDLCKYGIRL
  • MEMBER
  • 1998 OLDSMOBILE INTRIGUE
My car has had a severe problem now for a couple of years. I go to get on the gas and it hesitates, shakes, and back fires. We have changed coils, MAP sensor, spark plugs, fuel filter, oxygen sensor and nothing seems to change how the car runs! Please help!
Do you
have the same problem?
Yes
No
Wednesday, April 15th, 2009 AT 2:32 PM

18 Replies

Tiny
RASMATAZ
  • MEMBER
Dirty fuel injectors (cleaning the injectors often fixes this).
Bad TPS (throttle position) sensor
Bad or dirty MAF (mass airflow) sensor
Low fuel pressure (leaky fuel pressure regulator or weak fuel pump)
Vacuum leaks (intake manifold, vacuum hoses, throttle body, EGR valve)
Bad gasoline (fuel contaminated with water or too much alcohol)

Has the check engine light ever come on during this problem? If so scanning it for codes could help pinpoint the problem instead of just throwing parts at it.
See the article below on code gathering

https://www.2carpros.com/articles/checking-a-service-engine-soon-or-check-engine-light-on-or-flashing

And this one on Hesitation- it may give you some more insight

https://www.2carpros.com/articles/engine-hesitates

Let us know what you find
Was this
answer
helpful?
Yes
No
Wednesday, April 22nd, 2009 AT 7:32 PM
Tiny
TIGERBUCK57
  • MEMBER
  • 1998 OLDSMOBILE INTRIGUE
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 110,000 MILES
My car has a hesitation and stalls. It all started five days ago and I have not driven it more that a few miles since. It starts to hesitate anytime after about one mile of driving. It has stalled on me four time time, all after the car has warmed up. The first three were within about half a mile. Also, when looking over the engine after the stalls, with no on in the car, it revved up then wanted to shut off. It does this several times then idles smoothly for a minute or so the repeats. We change the spark plugs and are considering changing the coil packs. Do you have any suggestions we can look at first?

Thanks,
Rick
Was this
answer
helpful?
Yes
No
Monday, September 24th, 2018 AT 4:58 PM (Merged)
Tiny
RASMATAZ
  • MEMBER
Inspect and test all the following listed below:

Oxygen sensor.
Catalytic converter.
Fuel injectors dirty/sticking.
Mass airflow sensor/Airflow meter.
Throttle position sensor.
Manifold absolute pressure sensor.
EGR Valve
Fuel pressure regulator leaking or defective fuel pump.
False air leakage.
Fuel contamination.
Foul/defective spark plugs.
Open spark plug wires.
Ignition coil/Coil packs defective.
Incorrect ignition timing.
Cap and rotor.
Was this
answer
helpful?
Yes
No
Monday, September 24th, 2018 AT 4:58 PM (Merged)
Tiny
ALLEN_INTRIGUE
  • MEMBER
  • 1999 OLDSMOBILE INTRIGUE
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 156,000 MILES
The car starts fine and drives fine but some times when slowing to to stop at a light to make a turn or just to stop because the lights red it will act like it wants to stall but does not, when this happens the headlights go dim. It only happens sometimes and the GM people checked it out and do not know. I changed the IAC and cleaned out the throttle body.(Well the people at GM did). I cleaned the battery cables and changed the battery. It still does it. When sitting it idles fine. It is just after driving and I start to slow down it will do it. It does it when I take my foot off the gas.
Was this
answer
helpful?
Yes
No
Monday, September 24th, 2018 AT 4:58 PM (Merged)
Tiny
SCOTTY DEE
  • MEMBER
Are there any trouble codes stored?
Was this
answer
helpful?
Yes
No
Monday, September 24th, 2018 AT 4:58 PM (Merged)
Tiny
ALLEN_INTRIGUE
  • MEMBER
No there are not. Just the ABS but that would not have anything to do with it. I would give money on here if I could, but I do not have a card, lol. Or much money because GM charged me $425.00 for that. My Oldsmobile has a 3.5 twin cam if that helps. This only happens to me when I am going 30 mph or under.
Was this
answer
helpful?
Yes
No
Monday, September 24th, 2018 AT 4:58 PM (Merged)
Tiny
SCOTTY DEE
  • MEMBER
Is the air filter box and air horn sealed good?
Was this
answer
helpful?
Yes
No
Monday, September 24th, 2018 AT 4:58 PM (Merged)
Tiny
ALLEN_INTRIGUE
  • MEMBER
Yes it is. I just had it off and was checking it out yesterday. This is on odd one is it not?
Was this
answer
helpful?
Yes
No
Monday, September 24th, 2018 AT 4:58 PM (Merged)
Tiny
SCOTTY DEE
  • MEMBER
3.5L or 3.8L engine?
Was this
answer
helpful?
Yes
No
Monday, September 24th, 2018 AT 4:58 PM (Merged)
Tiny
DDABH
  • MEMBER
  • 2000 OLDSMOBILE INTRIGUE
  • 130,000 MILES
My car was running poorly during fast acceleration and at speeds over 60 mph. I had the O2 sensor replaced and the MAFS cleaned and re-calibrated. The car ran perfect for about three months. It started stumbling again. I replaced the MAF's with a re-manufactured one from the parts store. Service codes were reading P0031 and P0037. While sitting in park and flooring it, at exactly 4,000 rpm the engine cuts out and falls back to 3,700 rpm, then races back up to 4,000 to cut out again, and cycles like this until I let up off of the gas. The car runs okay while at 30 to 40 mph as long as I do not try to take off quickly. But if I floor it, forget it. It stumbles badly until I let off the gas. Same at highway speeds over 60 mph. To go over 60 mph I have to floor it and hold it there. Any ideas? No other codes reported from my CP9580. Thanks!
Was this
answer
helpful?
Yes
No
Monday, September 24th, 2018 AT 4:58 PM (Merged)
Tiny
ALLEN_INTRIGUE
  • MEMBER
3.5 twin-cam.
Was this
answer
helpful?
Yes
No
Monday, September 24th, 2018 AT 4:58 PM (Merged)
Tiny
RASMATAZ
  • MEMBER
Go to this link: http://www.2carpros.com/articles/engine-hesitates
Was this
answer
helpful?
Yes
No
+1
Monday, September 24th, 2018 AT 4:58 PM (Merged)
Tiny
SCOTTY DEE
  • MEMBER


http://www.2carpros.com/forum/automotive_pictures/470594_Intrigue_2.jpg

Was this
answer
helpful?
Yes
No
Monday, September 24th, 2018 AT 4:58 PM (Merged)
Tiny
ALLEN_INTRIGUE
  • MEMBER
How can I see that bigger? Is there a URL or anything? What does it mean if your coolant reservoir has almost topped itself off. I was just looking at it and I remembered it last week seeing quarter filled where it is meant to be. Now it is almost filled and I added nothing to it. And the car has been siting for six hours.
Was this
answer
helpful?
Yes
No
Monday, September 24th, 2018 AT 4:58 PM (Merged)
Tiny
SCOTTY DEE
  • MEMBER
Highlight the image andright click save picture as, and save to your pictures. Coolant overflow was full of coolant! Holy ding dong dung!

We need to block test for exhaust gasses in the cooling system.

Did you give me feedback yet?
Was this
answer
helpful?
Yes
No
Monday, September 24th, 2018 AT 4:58 PM (Merged)
Tiny
ALLEN_INTRIGUE
  • MEMBER
What dos that mean? Bad thing and probably should find a ride to work in the morning? Lol
Was this
answer
helpful?
Yes
No
Monday, September 24th, 2018 AT 4:58 PM (Merged)
Tiny
SCOTTY DEE
  • MEMBER
I am not going to speculate at this time, but have it checked out right away. Let me know please.
Was this
answer
helpful?
Yes
No
Monday, September 24th, 2018 AT 4:58 PM (Merged)
Tiny
ALLEN_INTRIGUE
  • MEMBER
Well, I took if for a drive five minutes ago up the road and it filled up more. The car did not seem to get as warm inside as fast as it did, but I do not know. It maybe just trying to understand what is going on.
Was this
answer
helpful?
Yes
No
Monday, September 24th, 2018 AT 4:58 PM (Merged)

Please login or register to post a reply.

Recommended Guides