No power after replacing the catalytic converter

Tiny
YOITSJUSTME
  • MEMBER
  • 1994 FORD RANGER
  • 4.0L
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 215,000 MILES
I have a rough idle and when I put the gas pedal to the floor it does not pick up the speed at all. I have changed all the plugs and wires, I changed fuel filter. The idle seems a little better after the fuel filter but still no power. One day I drove about 20 miles when I pulled in a Quik Trip and all of sudden the truck was jerking only it wasn't jerking forward it was side to side like someone was shaking the truck and all the gauges on the dash were all going crazy and then the check engine light came on. Right after this incident was when the plugs and wires were changed, new catalytic converter was put on and then it started the no power. It really seems like something is plugged up. Tired of searching please help.
Do you
have the same problem?
Yes
No
Monday, June 14th, 2021 AT 10:25 AM

1 Reply

Tiny
KENNY K
  • EXPERT
Just to be clear, there was no issue before you put the converter on it and now all this started?

If so, what was the reason for replacing the converter? Where did you get the converter? Was it new or used?

It sounds like the converter is plugged so we need to explore that.

https://www.2carpros.com/articles/bad-catalytic-converter-symptoms

I would suggest starting with removing the upstream o2 sensors and drive the vehicle to see if the power is a little better. Clearly this is not going to free it up completely but you should see a difference.

Please let us know what you find with this.

Thanks
Was this
answer
helpful?
Yes
No
Tuesday, June 15th, 2021 AT 5:14 PM

Please login or register to post a reply.

Sponsored links