No fuel to schrader valve after new fuel pump installed.

Tiny
GRANDDAD
  • MEMBER
  • 2001 SATURN SL2
  • 1.9L
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 110,000 MILES
First, would crank well but not start. Found no fuel at schrader valve and fuel gauge reading empty with tank half full.

Cleaned gas tank, replaced fuel pump, fuel pickup filter, fuel line filter and fuel fuses in under hood fuse box and on passenger side of center console. Car ran for 5 days <50 miles.

Now same problem except fuel gauge is accurate. Replaced what looked to be good fuses again and replaced fuel pump relay. Still no fuel to engine. Cranks well.

Tried to test with OBDII (with key in on position) but "failed to communicate" - cleaned and check grounding of ECM. Tried again failed to "Comm."

I am stumped. Help.
Do you
have the same problem?
Yes
No
Saturday, May 9th, 2015 AT 2:08 PM

6 Replies

Tiny
SATURNTECH9
  • EXPERT
Which code reader do you have? Also do you have power to the fuel pump fuse while cranking the engine?
Was this
answer
helpful?
Yes
No
Saturday, May 9th, 2015 AT 6:41 PM
Tiny
2CARPROS MIKE
  • ADMIN
GrandDad
Tuesday, May 12, 2015

OBDII Yes fuel pump fuse is hot when cranking.
Was this
answer
helpful?
Yes
No
Tuesday, May 12th, 2015 AT 2:21 PM
Tiny
GRANDDAD
  • MEMBER
The OBDII was made by INNOVA it's latest model. The ignition was on when I tried to test for error codes.
Was this
answer
helpful?
Yes
No
Tuesday, May 12th, 2015 AT 3:16 PM
Tiny
SATURNTECH9
  • EXPERT
Do you have power to the orange wire at the obd2 connector? Do any of the terminals at the obd 2 connector look open more the other ones?Will your code reader turn on without it being connected to the obd2 connector?
Was this
answer
helpful?
Yes
No
Tuesday, May 12th, 2015 AT 8:49 PM
Tiny
GRANDDAD
  • MEMBER
My son wanted to help me. So I tried cranking it and it started then died in about 10 seconds. Did this several times then kept running. So drove to auto parts store and scanned for errors - - there were not. I guess only God knows.

But now have problem with 2005 Tiberon. Getting rapid clicking when trying to crank. Replaced starter, battery OK, Any ideas on this?
Was this
answer
helpful?
Yes
No
Thursday, May 14th, 2015 AT 5:14 PM
Tiny
SATURNTECH9
  • EXPERT
Keep me posted on the saturn if it acts up again problems usually dont fix themselves they just lay dormant till they acted up again. As far as your other car iam going to have to ask you to start another question under that vehicle with its problem. We try to help as many people as we can on this site. Others will search for your other car with a similar problem but wont find it buried in your saturn question.
Was this
answer
helpful?
Yes
No
Thursday, May 14th, 2015 AT 9:01 PM

Please login or register to post a reply.

Recommended Guides