Fuel pump

Tiny
CSENGLE
  • MEMBER
  • NISSAN SENTRA
I have a '93 Nissan Sentra w/1.6 L engine. The car had been sitting for 1yr without being drivin. Recently I started driving it again and it overheated which cranked the head. Since the car had 231,000 miles on it, I opted to put in a new, used engine. The car would start with aid of starting fluid. It was determined it needed new fuel pump. Fuel pump was replaced and it ran for couple of hours and then the relay start making a loud noise and the fuel pump died. I was told the gas was probably bad and was wrecking the pumps.I drained the tank, replaced the relay and put in another new pump. Nothing. The fuse in the dash is good. Is there an inline fusible link somewhere?
Do you
have the same problem?
Yes
No
Tuesday, July 17th, 2007 AT 11:06 AM

2 Replies

Tiny
RASMATAZ
  • MEMBER
When key is in On position, do you hear the pump for 2 secs?

No buzz/humm-disconnect the wire connector at pump check black/red for power-No power -check Brn wire and black/red at relay-is there 12volts on both when key is in On position.

2pumps-did you change the fuel filter on the firewall.
Was this
answer
helpful?
Yes
No
Wednesday, July 18th, 2007 AT 6:01 AM
Tiny
CSENGLE
  • MEMBER
Yes I changed the relay and the fuel filter. I did not hear the fuel pump turn on. Although there was power to the source. My brand new $200 fuel pump was bad. My $22 pump from the junk yard fired the car right up! Thanks for keeping me focused on the basics.
Was this
answer
helpful?
Yes
No
Tuesday, July 24th, 2007 AT 7:57 AM

Please login or register to post a reply.

Recommended Guides