Backfiring and cutting out

Tiny
MARC KIDNEY
  • MEMBER
  • 1992 FORD RANGER
  • 2.3L
  • 4 CYL
  • RWD
  • MANUAL
  • 250,000 MILES
Hello my name is Marc. I just recently purchased this truck. It ran great for like three days and then all the sudden started jumping around on me and backfiring and jumping a lot. Lol. Then it got to the point where I lost power and it would not even start again. When it runs it seems to run great, but when that starts happening I have to let it cool off for quite a while and then do it again. Its not really even drive-able at this point because it happened so soon. Anybody have any ideas? I already changed the ignition module sensor. And I do not have power for them to check codes on shop my connector has no power to it for some reason. All the fuses were tested and tested good. Please help! Thank you so much everybody! :-)
Do you
have the same problem?
Yes
No
Monday, May 30th, 2016 AT 3:23 PM

2 Replies

Tiny
HMAC300
  • EXPERT
Check items in picture fuses and fusible link, then check fuel pressure with a gauge it the pump may be getting hot and not working.

https://www.2carpros.com/articles/how-to-check-fuel-system-pressure-and-regulator

I am assuming the battery is in good condition and has been load tested as well as timing belt is in good condition as well.
Was this
answer
helpful?
Yes
No
+1
Monday, May 30th, 2016 AT 4:16 PM
Tiny
HMAC300
  • EXPERT
Forgot picture.
Was this
answer
helpful?
Yes
No
Monday, May 30th, 2016 AT 4:16 PM

Please login or register to post a reply.

Recommended Guides