Enging Sputters

Tiny
RICKY1Y
  • MEMBER
  • 1992 FORD RANGER
Engine Performance problem 6 cyl Two Wheel Drive Automatic 170000 miles

When I start up my truck it runs good for 5 to 10 minutes and then it starts to sputter and lose power and wants to die. I get it home and let it sit for a few hours and start it up again and it will run fine and start all over again with the same problem. What is the problem and what do I do?
Do you
have the same problem?
Yes
No
Tuesday, September 7th, 2010 AT 11:43 AM

10 Replies

Tiny
BILLYMAC
  • EXPERT
Have your ignition module checked
Was this
answer
helpful?
Yes
No
Sunday, September 12th, 2010 AT 9:29 PM
Tiny
LELAND'S RANGER
  • MEMBER
Mine does the same.
Was this
answer
helpful?
Yes
No
Saturday, October 28th, 2017 AT 7:54 PM
Tiny
KEN
  • ADMIN
It sounds like you have a vacuum leak which will cause the engine to run okay when cold but then when it heats up it will start to stall and idle rough.

Here is two guides that should help us get the problem fixed.

https://www.2carpros.com/articles/how-to-use-an-engine-vacuum-gauge

and

https://www.2carpros.com/articles/stall-at-idle

Please run this test and get back to us so we can keep helping you.

Cheers, Ken

Was this
answer
helpful?
Yes
No
Monday, October 30th, 2017 AT 1:34 PM
Tiny
LELAND'S RANGER
  • MEMBER
Well it didn't work. No vacum leaks, new fuel filter didn't help either
Was this
answer
helpful?
Yes
No
Tuesday, October 31st, 2017 AT 3:39 PM
Tiny
KEN
  • ADMIN
Can you make a quick video so I can see how the engine is running. You can upload it here in your reply. This way I wont have to guess.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Wednesday, November 1st, 2017 AT 6:18 PM
Tiny
LELAND'S RANGER
  • MEMBER
Here's the video. Hopefully this will help you :)
Was this
answer
helpful?
Yes
No
Wednesday, November 1st, 2017 AT 6:54 PM
Tiny
KEN
  • ADMIN
O ya, a video is worth so much, you see how the check engine light flickers, this is a sign of a couple things first is the system can have a bad ground or the ECM is out and needs replacement. Here is a guide so you can check the ECM grounds.

https://www.2carpros.com/articles/how-to-use-a-test-light-circuit-tester

and

https://www.2carpros.com/articles/how-to-check-wiring

Here is the ECU location and the main system ground location as well. If the grounds check out you should be able to get a used ECM and plug it in. There is also a ECC relay I would swap out as well. Also check the battery cables they need to be clean and tight

https://www.2carpros.com/articles/everything-goes-dead-when-engine-is-cranked

Diagrams (Below)

Please let us know what you find. I'm interested to see what it is.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Thursday, November 2nd, 2017 AT 9:47 AM
Tiny
LELAND'S RANGER
  • MEMBER
Do you think it could be because of a bad battery? Mine is completely shot and just jump start it everyday. The ecm is kinda expensive so I was just wondering if the battery is a contributing factor? Also I thought about an Ignition control module. I will check grounds and so forth.
Was this
answer
helpful?
Yes
No
Thursday, November 2nd, 2017 AT 6:17 PM
Tiny
LELAND'S RANGER
  • MEMBER
I checked as many grounds for the ecm and other random grounds. It's 10:55 pm so I'm going to bed and will check other grounds put in a new battery, and all that stuff tomorrow. Also I want to thank you for your help! It's been very good and you have way better ideas than me! I don't know how you can just answer people's stupid questions all day! Anyway I think your a great help and it's much appreciated!
Was this
answer
helpful?
Yes
No
Thursday, November 2nd, 2017 AT 7:58 PM
Tiny
KEN
  • ADMIN
A bad battery could cause the trouble I would replace the first.

https://www.2carpros.com/articles/how-to-replace-a-car-battery

Please let us know what happens so it will help others.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Friday, November 3rd, 2017 AT 1:18 PM

Please login or register to post a reply.

Recommended Guides