No power to the injectors and fuel pump

Tiny
JED HALL
  • MEMBER
  • 1999 FORD F-150
  • 4.2L
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 1,117,865 MILES
My fuel pump and injectors are not getting power. I checked all of the fuses and they are all good. Also, the check engine light is not coming on.
Do you
have the same problem?
Yes
No
Friday, November 11th, 2016 AT 6:36 AM

3 Replies

Tiny
AL514
  • EXPERT
You may have a corrosion issue at this junction point for all these red power wires. Power is coming from fuse #18 -15 amp. Make sure you have power on both sides of this fuse to begin with and work your way towards that junction point. Ford loves to keep all its power wires red running all over the place. See if the fuel pump relay is getting power on the #86 pin of the relay.
Hopefully this helps.
Was this
answer
helpful?
Yes
No
+2
Friday, November 11th, 2016 AT 8:57 AM
Tiny
AL514
  • EXPERT
Are you getting any spark?
Was this
answer
helpful?
Yes
No
+5
Friday, November 11th, 2016 AT 9:02 AM
Tiny
WRENCHTECH
  • MEMBER
In this circuit the PCM power relay supplies power for both the fuel injectors, the fuel pump relay and the PCM. Since you are not getting a check engine light, the PCM is not powering up at all. It may be dead or it may have a blown fuse somewhere or the relay itself could be bad.

https://www.2carpros.com/images/external/220938772.gif
Was this
answer
helpful?
Yes
No
+5
Friday, November 11th, 2016 AT 10:31 AM

Please login or register to post a reply.

Sponsored links