Black Smoke and Runs Rich

Tiny
DAMON
  • MEMBER
  • GMC SAFARI
I have a 1992 GMC Safari SLE 4.3L CMFI Motor 2WD 201005 Miles that is blowing out black smoke, has a very rich gas smell and has went from 22 MPG to 6MPG. I did a code check and got one error Code 45 rich exhaust, I cleared the code and drove about a block and rechecked
and recieved no code. This is what I have done to try to fix it, I have replaced the oxygen sensor, coil, distributor picup, rotor and cap, engine temp switch, oil sending unit, and I did a fuel pressure test that was within range.

Anyone have any ideals?
Do you
have the same problem?
Yes
No
Saturday, May 6th, 2006 AT 8:16 PM

2 Replies

Tiny
BURRBRIAN
  • MEMBER
I think if I went that far plugs would probably be in order along with a compression check. Sounds like you could have oil rings wore out. These electronic and computerized things aren't really my strong areas but seems like like you are passing a lot of unburnt fuel and burning some oil. Are you going through a lot of oil? Lost some of the git-up-and-go that it used to have?With that many miles on it you may be looking at things just being plumb wore out internally, meaning a rebuild is something you might consider in the near future. But on this my word is not gospel, just some more things to look at.
Was this
answer
helpful?
Yes
No
Sunday, May 7th, 2006 AT 9:09 AM
Tiny
DAMON
  • MEMBER
The motor ran great untill the fuel problem. Lots of get up and go, no smoke, burned a little oil, maybe a quart every six months or so. I am going to check a couple more parts, MAP sensor, TPS Sensor before I take it in somewhere.

Thanks for the responce.
Damon
Was this
answer
helpful?
Yes
No
Monday, May 8th, 2006 AT 12:19 PM

Please login or register to post a reply.

Recommended Guides