So I'm thinking that it's the fuel pump

Tiny
MORGAN LITTLE
  • MEMBER
  • 1989 MITSUBISHI LANCER
  • 1.5L
  • 4 CYL
  • 2WD
  • MANUAL
  • 17,508 MILES
Hi, fuel is not getting to first or second fuel filter. So i'm thinking that it's the pump. In most other cars the pump is under the seat but mine is not. Just wondering if I would have to drop the tank or not. Thanks
Do you
have the same problem?
Yes
No
Saturday, November 21st, 2020 AT 3:11 PM

5 Replies

Tiny
KASEKENNY
  • EXPERT
I am attaching the process from the USA version of the Lancer. They did not offer the Lancer in the USA in this year so we don't have that specific vehicle but the Galant was basically the same vehicle. You are correct that this is removed from under the vehicle.

As for the issue, I am not sure this is a pump issue. If it is running like that with all that blue/white smoke I think you have other issues.

I would start with checking the fuel pressure before you replace the pump.

https://www.2carpros.com/articles/how-to-check-fuel-system-pressure-and-regulator

Once we know what the pressure is we can determine the next steps. However, I would start with checking the compression and going from there.

https://www.2carpros.com/articles/how-to-test-engine-compression

Let us know and we can go from there. Thanks
Was this
answer
helpful?
Yes
No
+1
Wednesday, March 31st, 2021 AT 12:33 PM
Tiny
MORGAN LITTLE
  • MEMBER
Hi, thanks. We got fuel going to the filters now, but fuel is not going to the cylinders and the smoke has stopped as well. We think it's an electrical problem.
Was this
answer
helpful?
Yes
No
Wednesday, March 31st, 2021 AT 12:33 PM
Tiny
KASEKENNY
  • EXPERT
Okay. I am not sure this is the issue because how is the vehicle running if you don't have fuel going through to the cylinders? If the vehicle is running but running poorly then you have spark and fuel but maybe they are weak but again, if the engine is running then you have fuel.

Maybe I am not understanding the issue so let us know what we are missing. Thanks
Was this
answer
helpful?
Yes
No
+1
Wednesday, March 31st, 2021 AT 12:33 PM
Tiny
MORGAN LITTLE
  • MEMBER
Sorry didn t add that we are dumping fuel into the intake and when we do it s sounds and runs good.
Was this
answer
helpful?
Yes
No
Wednesday, March 31st, 2021 AT 12:33 PM
Tiny
KASEKENNY
  • EXPERT
Okay. So just to be clear the vehicle is only running if you are adding fuel to the intake? If that is the case then I am in agreement that you have a delivery issue. So if you have proper pressure we need to check the injectors with a noid light or test light. However, have we confirmed the pressure is correct? I am not seeing that it was or maybe I just missed that.

https://www.2carpros.com/articles/how-to-check-fuel-system-pressure-and-regulator

Let us know this info and we can go from there. Thanks

https://www.2carpros.com/articles/how-to-test-a-fuel-injector
Was this
answer
helpful?
Yes
No
Wednesday, March 31st, 2021 AT 12:33 PM

Please login or register to post a reply.

Sponsored links