2002 Chrysler Town and Country RH Turn Signals Quit

Tiny
CJS45LJ
  • MEMBER
  • 2002 CHRYSLER TOWN AND COUNTRY
Electrical problem
2002 Chrysler Town and Country 6 cyl Front Wheel Drive Automatic

Hi,

The RH (front & back) turn signals quit working on my 2002 Town & Country. You can hear a flasher clicking in the dash when you turn on the RH signal and the indicator in the dash flashes at the normal speed but the front and rear turn signals do not light up. I checked the bulbs and they are good and I also replaced the turn signal switch in the colum but that didn't fix it either. Do you know where I can get a wiring diagram or even better what is causing this problem?

Thanks,
Cliff
Do you
have the same problem?
Yes
No
Sunday, September 19th, 2010 AT 12:45 PM

8 Replies

Tiny
DOCFIXIT
  • EXPERT
Hi
Does tail light come on? If no check fuse #3 in Intelegent power module engine compartment. If yes maybe right turn signal relay inside left rear quater panel.
Let me know
Thanks for donate
Was this
answer
helpful?
Yes
No
Sunday, September 19th, 2010 AT 1:18 PM
Tiny
CJS45LJ
  • MEMBER
Thanks! I'm pretty sure I checked that fuse a couple of days ago and I have not been able to find the relay panel you spoke of. Is it behind the side wall or outside the passenger compartment?
Was this
answer
helpful?
Yes
No
Sunday, September 19th, 2010 AT 1:39 PM
Tiny
CJS45LJ
  • MEMBER
Yes the tail light comes on. I signed up for maintenance manuals and the wiring diagram shows a Body Control Module between the turn signal switch and the turn signal bulb. Does this mean that there is no relay and that the Body Control Module could be bad?
Was this
answer
helpful?
Yes
No
Sunday, September 19th, 2010 AT 1:56 PM
Tiny
DOCFIXIT
  • EXPERT
That is a strong possibility the relays are behind left rear panel need to remove to gaun access. If relay coil is faulty then right side would not work. The fact that light on dash blinks means BCM is working
Was this
answer
helpful?
Yes
No
Sunday, September 19th, 2010 AT 2:46 PM
Tiny
CJS45LJ
  • MEMBER
All fuses are good and I removed the whole left rear quater panel on the left side and there are no relays what so ever back there. I have 12 volts all the time (turn signal on or off) at the right rear turn signal lamp white/brown and a good ground on the black wire. The left turn signal operates fine and has no voltage with the turn signal off. This sounds to me like the Body Control Module is bad since that is the only thing the wiring diagram shows up stream of the bulb. Would you agree?
Was this
answer
helpful?
Yes
No
Sunday, September 19th, 2010 AT 4:22 PM
Tiny
DOCFIXIT
  • EXPERT
Left and right of a vehicle is from drivers seat the white/brown is for left side tail. Pull park relay from Intelligent module does 12 V go to zero?
Was this
answer
helpful?
Yes
No
Monday, September 20th, 2010 AT 1:01 PM
Tiny
CJS45LJ
  • MEMBER
I think you are looking at the wiring for the front turn signal and not the rear. I am using the diagram on eautorepair. Net and it matches the rear wire colors for an 02 Town & Country. White and brown are for the front left and right rear turn signals. Any way I did what you said and the 12v stays there when I remove the Park Lamp Relay.
Was this
answer
helpful?
Yes
No
Monday, September 20th, 2010 AT 10:30 PM
Tiny
DOCFIXIT
  • EXPERT
First post stated Right front and rear turn signals not work right? Did you find relays? Is there a trailer tow plug? With voltage on wht/brn light should be on all the time on right front voltage on wht/tan?
Was this
answer
helpful?
Yes
No
-1
Wednesday, September 22nd, 2010 AT 10:17 AM

Please login or register to post a reply.

Recommended Guides