Turn signals not working

Tiny
MSTRANDBERG
  • MEMBER
  • 2003 CHRYSLER TOWN AND COUNTRY
  • 40,000 MILES
I have a 2003 chrysler town and country. When you activate the turn siganls and the hazards they work on the instrument panal and not on the exterior of the viehicle. I have checked all of the fuses and the relays and the bulds. All of the rest of the lighting on the car works. What direction should I go with this?
Do you
have the same problem?
Yes
No
Saturday, September 10th, 2011 AT 4:43 PM

3 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
At this point, since you have done all the general checks, you need to start tracing wiring to see where power is lost. I would start at the multi-function switch on the steering.
Was this
answer
helpful?
Yes
No
-1
Saturday, September 10th, 2011 AT 5:27 PM
Tiny
MSTRANDBERG
  • MEMBER
Well from there the wires go from the Multifunction switch to the BCM I am asking if there is a some kind of common problem or a related item to where the dealer would plug into the BCM and manually try to make the blinkers work so I would not have to pay 100 bucks for the test. There are a considerable ammount of wires headed to the same direction and in the same wiring bundles. Any further help would be awesome.
Was this
answer
helpful?
Yes
No
-2
Tuesday, September 13th, 2011 AT 9:17 PM
Tiny
RANDYLYNCH32
  • MEMBER
I know this has been posted a while ago but what ever came of it? I have the same issue
Was this
answer
helpful?
Yes
No
-1
Thursday, May 22nd, 2014 AT 9:16 AM

Please login or register to post a reply.

Sponsored links