1999 Chevy S-10 Fuel Pump. Maybe IDK?

Tiny
KYLEKALLAS
  • MEMBER
  • 1999 CHEVROLET S-10
  • 4 CYL
  • 2WD
  • MANUAL
  • 15,500 MILES
I cant get my truck started, when I turn the key it just doesnt want fire, and I think cuz its not getting gas, I cant smell gas when I try to start it at all. I changed out the old plugs and wires, changed the fuel filter, IDK I'm lost at this point?
Do you
have the same problem?
Yes
No
Friday, November 5th, 2010 AT 11:26 AM

3 Replies

Tiny
WRENCHTECH
  • EXPERT
All "crank, no start" conditions are approached in the same way. Every engine requires certain functions to be able to run. Some of these functions rely on specific components to work and some components are part of more than one function so it is important to see the whole picture to be able to conclude anything about what may have failed. Also, these functions can ONLY be tested during the failure. Any other time and they will simply test good because the problem isn't present at the moment.
If you approach this in any other way, you are merely guessing and that only serves to replace unnecessary parts and wastes money.

Every engine requires spark, fuel and compression to run. That's what we have to look for.

These are the basics that need to be tested and will give us the info required to isolate a cause.

1) Test for spark at the plug end of the wire using a spark tester. If none found, check for power supply on the + terminal of the coil with the key on.

2) Test for injector pulse using a small bulb called a noid light. If none found, check for power supply at one side of the injector with the key on.

3) Use a fuel pressure gauge to test for correct fuel pressure, also noticing if the pressure holds when key is shut off.

4) If all of these things check good, then you would need to do a complete compression test.

Once you have determined which of these functions has dropped out,
you will know which system is having the problem.
Was this
answer
helpful?
Yes
No
Friday, November 5th, 2010 AT 11:27 AM
Tiny
KYLEKALLAS
  • MEMBER
I'm kinda at that point now like thats the only thing else I can think of tha t could be the problem, like it was running fine no problems drove to a friends house parked it maybe an hour got back in it tried to start it and nothing, but over the past 5 days that its not been workin, I have started it up and a couple of times I had it started but only for a sec and then back to nothing?
Was this
answer
helpful?
Yes
No
Friday, November 5th, 2010 AT 11:38 AM
Tiny
WRENCHTECH
  • EXPERT
Post back with the results of ALL of those tests and then I can help you.
Was this
answer
helpful?
Yes
No
Friday, November 5th, 2010 AT 11:43 AM

Please login or register to post a reply.

Recommended Guides