1990 Chevy S-10 diagnosis

Tiny
DOTTERSON
  • MEMBER
  • 1990 CHEVROLET S-10
Engine Mechanical problem
1990 Chevy S-10 Four Wheel Drive Automatic

I was driving and my car just died, it would not restart. We replaced the battery and the positive cable and it started. We moved the car and when my daughter went to start it it cranked and wouldnt turn over. The fuel pump is running, so we replaced the fuel filter which was colgged and then the car started again right away. We turned it off and it started again, but the 3rd time it did the same crank and not start thing. We cant figure it out.
Do you
have the same problem?
Yes
No
Saturday, October 25th, 2008 AT 1:26 PM

4 Replies

Tiny
RASMATAZ
  • MEMBER
Hi dotterson and welcome to 2carpros

Lets try checking the fuel pressure to rule out the fuel pump and comeback with the readings so that we can continue to assist.

Or if you want do below and tell me what happened

Get a carb cleaner and spray into the carb or the throttle body on an EFI. Did it start and die? If not disconnect a sparkplug wire or 2 and ground it to the engine -have helper crank engine over-do you have a snapping blue spark? If so-you have a fuel related problem, check the fuel pressure to rule out the fuel filter/fuel pump/pressure regulator and listen to the injector/s are they pulsing or hook up a noid light. No snapping blue spark continue to troubleshoot the ignition system-power input to the coil/coil packs, distributor pick-up coil, ignition control module, cam and crank sensors- Note: If it doesn't apply disregard it
Was this
answer
helpful?
Yes
No
Saturday, October 25th, 2008 AT 2:55 PM
Tiny
DOTTERSON
  • MEMBER
Hi, thanks for the reply. Ok we took out spark plug it had a spark, We put plug back in car started right away. We let it run and in about 3 minutes it just died, no sputter, just shut off and died. Now it wont start again. It is cranking but not starting. What should we check next?
Was this
answer
helpful?
Yes
No
Sunday, October 26th, 2008 AT 11:42 AM
Tiny
DOTTERSON
  • MEMBER
Oh, also we took the plug back out again and now it is not sparking.
Was this
answer
helpful?
Yes
No
Sunday, October 26th, 2008 AT 12:01 PM
Tiny
RASMATAZ
  • MEMBER
See no start troubleshooting below


http://www.2carpros.com/forum/automotive_pictures/12900_is1_2.jpg



http://www.2carpros.com/forum/automotive_pictures/12900_is2_2.jpg



http://www.2carpros.com/forum/automotive_pictures/12900_is3_1.jpg

Was this
answer
helpful?
Yes
No
Sunday, October 26th, 2008 AT 2:19 PM

Please login or register to post a reply.

Recommended Guides