No injector Pulse no start

Tiny
DENO1313
  • MEMBER
  • 1996 CHEVROLET S-10
  • 4.3L
  • 6 CYL
  • 4WD
  • AUTOMATIC
  • 200,000 MILES
I have no injector pulse and truck will not start. Replaced distributor five months ago. Just replaced fuel pump and filter. Replaced crank positioning sensor and computer. I get spark at plugs but no pulse to the injector therefore no fuel and no start. I do have fuel pressure. Not sure where to look from here. From what I can see wiring looks okay with no kinks, breaks or burns.
Do you
have the same problem?
Yes
No
Wednesday, July 15th, 2015 AT 9:32 PM

29 Replies

Tiny
SATURNTECH9
  • EXPERT
So key in the run position you have battery voltage to all the injectors and your just missing the ground pulse side of the injector control? I would check the fuse #10 which powers the injectors. Here is a guide on how to test for power at the fuse:

https://www.2carpros.com/articles/how-to-check-a-car-fuse

Here is a engine wiring diagrams so you can see how the ignition works.

Check out the diagrams (below). Please let us know what you find. We are interested to see what it is.

Cheers
Was this
answer
helpful?
Yes
No
+6
Wednesday, July 15th, 2015 AT 10:19 PM
Tiny
GWENG7
  • MEMBER
I have this problem #2 injector was shorted blew the fuse had to replace it all fixed now. I love this site.
Was this
answer
helpful?
Yes
No
+1
Saturday, June 30th, 2018 AT 1:47 PM
Tiny
HESTERTANK
  • MEMBER
  • 1995 CHEVROLET S-10
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 108,000 MILES
I have checked all the fuses and fusible links I have fire to the plugs. I have a pulse on white wire from distributor to ext coil. I replaced ECM just to see if that would fix it, no it didn't. It has a new GM fuel pump. Any help I have worked on this truck for 3 days and can't find the problem. Thank Gary
Was this
answer
helpful?
Yes
No
-1
Monday, December 2nd, 2019 AT 12:49 PM (Merged)
Tiny
MASTERTECHTIM
  • EXPERT
Gary I need a little more to work on. Does it run on starter fluid? This is a vortec engine, eigth letter of vin w? Any codes?
Was this
answer
helpful?
Yes
No
+4
Monday, December 2nd, 2019 AT 12:49 PM (Merged)
Tiny
HESTERTANK
  • MEMBER
It is a 4.3 Z engine code. It will run if you spray tbi cleaner into the throttle.
Was this
answer
helpful?
Yes
No
-2
Monday, December 2nd, 2019 AT 12:49 PM (Merged)
Tiny
MASTERTECHTIM
  • EXPERT
Z engine makes it a lot easier to diagnose. Does it have a check engine light on when the key is in the on position? Do you have 12 at the injector feed side? Are there any codes stored in memory?
Was this
answer
helpful?
Yes
No
-1
Monday, December 2nd, 2019 AT 12:49 PM (Merged)
Tiny
HESTERTANK
  • MEMBER
It does have voltage on the injector with the key in on position. The check engine light does not light up with the key on. The scanner will not communicate the ecm. The grounds are good on the ob connector it has voltage the ob connector and I checked the tan wire from the ob connector to the ecm no problem.
Was this
answer
helpful?
Yes
No
+1
Monday, December 2nd, 2019 AT 12:50 PM (Merged)
Tiny
MASTERTECHTIM
  • EXPERT
Thats where we need to start. Double check ecm fuse, its got to be blown or there is no power at ecm or the ecm is bad. You did check the ground wire for ecm at the thermostat housing?
Was this
answer
helpful?
Yes
No
-1
Monday, December 2nd, 2019 AT 12:50 PM (Merged)
Tiny
HESTERTANK
  • MEMBER
Both ecm fuses are good 20amp fuses i've checked and double checked power in the fuse panel all is good. I checked the ground on the ts housing and it is good. The ecm has ground where it suppose too according to the wiring diagrams. I looked today to find out why the scanner wouldin't communicate. I use 3 different scanners no communication. I've checked body grounds.
Was this
answer
helpful?
Yes
No
-1
Monday, December 2nd, 2019 AT 12:50 PM (Merged)
Tiny
ERIC MARTIN SCHMIDT
  • MEMBER
  • 1995 CHEVROLET S-10
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 112,000 MILES
What triggers the injectors---a B+ pulse or a ground pulse with a constant B+? I Can't seem to find anyone who can give me a wiring schematic for this related question, so can't test further to see if I need a computor or something else.I have fuel running to the fuel rack & back thru the return line; just not getting into the cyl's. B+ is present @ one side of all injector connections.
Was this
answer
helpful?
Yes
No
-1
Monday, December 2nd, 2019 AT 12:50 PM (Merged)
Tiny
RASMATAZ
  • EXPERT
Could be a problem with the computer injector/s driver or the computer is not getting an ignition reference signal from the CHM or pick-up coil.

Try using a noid lite and see if it blinks
Was this
answer
helpful?
Yes
No
Monday, December 2nd, 2019 AT 12:50 PM (Merged)
Tiny
OBXAUTOMEDIC
  • EXPERT
Hi Eric,

If you haven't already I would also check fuel pressure and Regulator. You stated you have fuel to rail and also back through return line. If pressure regulator is bad and letting fuel flow freely back to tank then would cause no or very little fuel in cylinders.

Check link below for checking fuel pressure

https://www.2carpros.com/how_to/how_to_check_fuel_pressure.htm

.
Was this
answer
helpful?
Yes
No
Monday, December 2nd, 2019 AT 12:50 PM (Merged)
Tiny
RODWHSA
  • MEMBER
  • 1991 CHEVROLET S-10
  • 2.5L
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 140,000 MILES
I have a 1991 Chevy S10 pickup, and the single fuel injector is not injecting gas. I don't think it is the injector, I installed a node light on the connection and it did not pulse. I ran a diagnosis with a Inoova tool kit and it says the computer does not have any DTC's. I used a meter and the red and blue wires to the connector seem to be live, so I don't think its a fuse, but I checked them anyways. Any thoughts?
Was this
answer
helpful?
Yes
No
+3
Monday, December 2nd, 2019 AT 12:50 PM (Merged)
Tiny
HOMER1967
  • EXPERT
Do you have spark to the spark plugs and/out of the coil?The injector should only spray when cranking.
Was this
answer
helpful?
Yes
No
+1
Monday, December 2nd, 2019 AT 12:50 PM (Merged)
Tiny
RODWHSA
  • MEMBER
Yes, the truck will run if I pour fuel into the carb.
Was this
answer
helpful?
Yes
No
+1
Monday, December 2nd, 2019 AT 12:50 PM (Merged)
Tiny
HOMER1967
  • EXPERT
Can you hear the fuel pump run?
Was this
answer
helpful?
Yes
No
+1
Monday, December 2nd, 2019 AT 12:50 PM (Merged)
Tiny
RODWHSA
  • MEMBER
Yes, the injector had fuel pressure to it. I just figured it out, when I plugged in the distributor, one of the pins got bent over and against the one beside it. Once I straightened that out, the distributor was able to send the pulse to the injector. Thanks for your advice!
Was this
answer
helpful?
Yes
No
+2
Monday, December 2nd, 2019 AT 12:50 PM (Merged)
Tiny
VICTOR MACKE
  • MEMBER
  • 1991 CHEVROLET S-10
  • 2.8L
  • 6 CYL
  • 2WD
  • MANUAL
  • 2,147,483,647 MILES
Completely new fuel system, both physical and electrical. Everything from the fuel pump and sending unit to a new distributor and injectors (TBI). Everything related to the fuel system is new. Not use. Why do I not have injector pulse? I only bought the truck for $500.00. It has already cost me over that in parts alone! Help me, please. Otherwise, there will be a giant bon fire in southwest Ohio. With an S-10 at its center.
Was this
answer
helpful?
Yes
No
-2
Monday, December 2nd, 2019 AT 12:50 PM (Merged)
Tiny
HOMER1967
  • EXPERT
That's great, your welcome. Thanks for letting me know.
Was this
answer
helpful?
Yes
No
+1
Monday, December 2nd, 2019 AT 12:50 PM (Merged)
Tiny
WRENCHTECH
  • EXPERT
I assume this must be a TBI system. Do you have 12 volts power on one side of the injector plug with the key on?
Was this
answer
helpful?
Yes
No
+11
Monday, December 2nd, 2019 AT 12:50 PM (Merged)

Please login or register to post a reply.

Sponsored links