Will not start unless primed?

Tiny
JOSE VILLARREAL
  • MEMBER
  • 1998 MAZDA 626
  • 2.0L
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 150,000 MILES
I have replaced several items to fix car vibration which was eventually fixed by replacing the gasket in the intake manifold which had a large leak. However, now the engine cranks but will start momentarily after priming with starting fluid. I checked the pressure between the hose that comes from the filter and the fuel pressure regulator. When I turn the key on, I get no reading, but when I crank it, I get a reading around 60. I replaced the following:

Fuel pressure valve
Fuel pump relay
MAF sensor
Both belts
Crankshaft position sensor
All fuel injectors
Throttle position sensor
Spark plugs
Spark plug cables
Distributor
All motor mounts
Downstream oxygen O2 sensor
Front oxygen O2 sensor
Idle control valve
Fuel filter
Some vacuum hoses
Fuel tank cap-tank is full
Throttle is clean
Air filter is clean
I am leaning to replace the fuel pump.
Tuesday, July 26th, 2022 AT 8:21 PM

25 Replies

Tiny
KEN L
  • MASTER CERTIFIED MECHANIC
  • 43,458 POSTS
Yep, you should hear the fuel pump in the tank when the key is turned on. here is how you can replace the fuel pump in the diagrams below. This is a generic guide below to show you what you are in for when doing the job. Also, have you run the codes?

https://www.2carpros.com/articles/checking-a-service-engine-soon-or-check-engine-light-on-or-flashing

and

https://www.2carpros.com/articles/how-to-replace-an-electric-fuel-pump

Check out the diagrams (below). Please let us know what happens.

Was this
answer
helpful?
Yes
No
+1
Wednesday, July 27th, 2022 AT 10:37 AM
Tiny
JOSE VILLARREAL
  • MEMBER
  • 18 POSTS
I installed the fuel pump, and I can hear it running when I turn the key on and stops. I then crank it and tries to start for a moment. Then it keeps cranking without start. I primed it twice and ran for a few seconds. What do you advise?
Was this
answer
helpful?
Yes
No
Wednesday, July 27th, 2022 AT 8:29 PM
Tiny
JOSE VILLARREAL
  • MEMBER
  • 18 POSTS
The problem with the engine not starting happened after I replaced the intake manifold gasket because of a vacuum leak. I had to remove several pieces of hardware from the intake manifold and I wonder if I didn't connect something correctly or damaged something.
Was this
answer
helpful?
Yes
No
Thursday, July 28th, 2022 AT 6:21 AM
Tiny
KEN L
  • MASTER CERTIFIED MECHANIC
  • 43,458 POSTS
Yep, that is what it sounds like there are ground wires that you need to make sure are connected to the engine. Were there any codes? We should check for spark as well.

This video will show you how:

https://youtu.be/baq_aEWNQ0Y

Let me know what happens.

Was this
answer
helpful?
Yes
No
Friday, July 29th, 2022 AT 9:27 AM
Tiny
JOSE VILLARREAL
  • MEMBER
  • 18 POSTS
Ground cables are okay. Strange that even when the car was running recently, I could not get any codes even when I pulled some sensor cables off on purpose. The engine still wants to start after some rest. Could the ECM be bad?
Was this
answer
helpful?
Yes
No
Friday, July 29th, 2022 AT 4:58 PM
Tiny
KEN L
  • MASTER CERTIFIED MECHANIC
  • 43,458 POSTS
That was my next suggestion, here is the location and how to change it out. Disconnect the battery first.
Was this
answer
helpful?
Yes
No
Saturday, July 30th, 2022 AT 12:54 PM
Tiny
JOSE VILLARREAL
  • MEMBER
  • 18 POSTS
After I installed the new fuel pump I could hear it priming each time I turned the key on. But since yesterday I can't hear it. I took the pump out and reinstalled. I still can't hear it priming. I ordered another pump which I will get tomorrow. If it turns out that the ECM is bad I will donate the car because it is too old to invest that kind of money in it.
Was this
answer
helpful?
Yes
No
Saturday, July 30th, 2022 AT 2:42 PM
Tiny
KEN L
  • MASTER CERTIFIED MECHANIC
  • 43,458 POSTS
Okay, you might be able to find a used ECM on Ebay. Also, I would change out the fuel pump relay again, it could be overloads from the bad pump. Here is how you can change the PCM out in the diagrams below. The ECM is plug and play.
Was this
answer
helpful?
Yes
No
Sunday, July 31st, 2022 AT 1:32 PM
Tiny
JOSE VILLARREAL
  • MEMBER
  • 18 POSTS
I ordered a used ECM from eBay. Will update you after I install it.
Was this
answer
helpful?
Yes
No
Sunday, July 31st, 2022 AT 9:55 PM
Tiny
KEN L
  • MASTER CERTIFIED MECHANIC
  • 43,458 POSTS
Sounds good.
Was this
answer
helpful?
Yes
No
Monday, August 1st, 2022 AT 2:01 PM
Tiny
JOSE VILLARREAL
  • MEMBER
  • 18 POSTS
I can't figure out how to access the ECM (how to remove dash parts).
Was this
answer
helpful?
Yes
No
Wednesday, August 3rd, 2022 AT 9:49 AM
Tiny
KEN L
  • MASTER CERTIFIED MECHANIC
  • 43,458 POSTS
This dash diagram should help. Check out the diagrams (below). Please let us know if you need anything else to get the problem fixed.
Was this
answer
helpful?
Yes
No
Wednesday, August 3rd, 2022 AT 11:11 AM
Tiny
JOSE VILLARREAL
  • MEMBER
  • 18 POSTS
Just installed the ECM from eBay it cranks but doesn't start like before. I primed it a few times and it acts like it want to start but nothing.
Was this
answer
helpful?
Yes
No
Thursday, August 4th, 2022 AT 2:01 PM
Tiny
JOSE VILLARREAL
  • MEMBER
  • 18 POSTS
I checked the new ECM before cranking and it had no codes. I tested it after a received no codes as well. Does it need to run for the ECM to show codes?
Was this
answer
helpful?
Yes
No
Thursday, August 4th, 2022 AT 2:06 PM
Tiny
KEN L
  • MASTER CERTIFIED MECHANIC
  • 43,458 POSTS
When the engine is cranking over does it sound normal? The engine does not need to run to show codes. Can you please shoot a quick video with your phone so I can hear the engine cranking it may have jumped time.
Was this
answer
helpful?
Yes
No
Thursday, August 4th, 2022 AT 7:05 PM
Tiny
JOSE VILLARREAL
  • MEMBER
  • 18 POSTS
Video of engine cranking attached. It sounds normal. The engine does not show codes even if I disconnect some sensors. Could the new ECM be bad? How about a poorly installed crankcase position sensor?
Was this
answer
helpful?
Yes
No
Friday, August 5th, 2022 AT 11:46 AM
Tiny
KEN L
  • MASTER CERTIFIED MECHANIC
  • 43,458 POSTS
Thanks for the video, did the engine do the same thing with the old ECM? It sounds like the ignition timing is way off. If the engine condition is the same lets install a new crankshaft position sensor. When you prime it and it starts does it run normally? Here is the location of the sensor. Let me know please.
Was this
answer
helpful?
Yes
No
Friday, August 5th, 2022 AT 6:17 PM
Tiny
JOSE VILLARREAL
  • MEMBER
  • 18 POSTS
I installed a new crank case positions sensor and I wonder if I didn't do it right? The engine tries to start by priming, but it doesn't start. The cranking is the same as with the old ECM.
Was this
answer
helpful?
Yes
No
Friday, August 5th, 2022 AT 6:29 PM
Tiny
KEN L
  • MASTER CERTIFIED MECHANIC
  • 43,458 POSTS
Let's remove the spark plugs to see what they look like please upload a picture of the plugs once removed.

https://www.2carpros.com/articles/how-to-change-spark-plugs

Please run down this guide and report back.
Was this
answer
helpful?
Yes
No
Saturday, August 6th, 2022 AT 7:36 PM
Tiny
JOSE VILLARREAL
  • MEMBER
  • 18 POSTS
The spark plugs were installed with correct gap after the trouble getting the engine started. Like I said before the spark plug cables, coil, injectors, fuel pressure regulator, fuel and air filters, fuel pump, are new and were replaced after the engine would not start. The car has 150,000 miles and when it was running it started right away, no smoke and at high RPMs the engine didn't miss or backfire.
Was this
answer
helpful?
Yes
No
Saturday, August 6th, 2022 AT 9:13 PM

Please login or register to post a reply.

Sponsored links