Second fuel pump, crank no start

Tiny
PETEMONTI
  • MEMBER
  • 2006 CHEVROLET EXPRESS
  • 4.8L
  • V8
  • 2WD
  • AUTOMATIC
  • 230,000 MILES
Hello,

I installed 2nd new fuel pump on my van.
Van started and ran fine.
Day later, it only cranked, but not start or ran.
Thanks again in advanced.

Best,
Pete
Do you
have the same problem?
Yes
No
Thursday, November 5th, 2020 AT 5:08 PM

2 Replies

Tiny
KASEKENNY1
  • EXPERT
We need to start with confirming that this is the fuel pump again. We can check fuel pressure or use starter fluid in the intake to see if it starts.

Here is a guide for the pressure:

https://www.2carpros.com/articles/how-to-check-fuel-system-pressure-and-regulator

Once we confirm the pump is the issue again, we need to check voltage at the pump. I assume something is burning up the pumps so the driver may be shorted. Here is the wiring diagram for the pump. Let's check how much voltage is on the gray wire going to the pump. Let me know if you have questions. Thanks
Was this
answer
helpful?
Yes
No
Thursday, November 5th, 2020 AT 5:18 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

Do you feel the no start is a result of the fuel pump? Have you checked for fuel pressure? Do me a favor, check to see if it starts for a couple of seconds and then stalls if you use starting fluid. If it does, then we know it is a fuel related issue. If you haven't, I would also check the fuel pressure to see if the pump is working.

https://www.2carpros.com/articles/how-to-check-fuel-system-pressure-and-regulator

If possible, let me know all that you have done since it is not starting again. We first need to confirm it is a spark or fuel related issue.

Just in case, here are a couple of links you may find helpful:

https://www.2carpros.com/articles/how-to-test-an-ignition-system

https://www.2carpros.com/articles/car-cranks-but-wont-start

Let me know.

Joe
Was this
answer
helpful?
Yes
No
Thursday, November 5th, 2020 AT 5:21 PM

Please login or register to post a reply.

Sponsored links