1997 Chevy Express Changed fuel pump. Ran for a week and di

Tiny
MDM6713
  • MEMBER
  • 1997 CHEVROLET EXPRESS
  • V8
  • 2WD
  • AUTOMATIC
  • 151,000 MILES
Hey guys, I installed a aftermarket fuel pump in my van. At first I couldnt get it to pump gas, it would only pump air. I removed the fuel pump cannister and fill the bottom cup with fuel and reinstalled into the tank. After the engine turned over a couple times it fired right up. I drove the truck for a week, about a 1/4 tank of gas used. Now, wont start again. I took the line loose where it close to the engine and put a rubber hose on it to see the fuel coming. It only pumped a few inches of fuel into the hose. I have very little fuel pressure. Any suggestions? Ive def. Got power there, you can hear the pump running for two secs upon key on, then it will continue to run a few secs after I stop cranking the motor. Please advice ye great ones ;o)
Michael
Do you
have the same problem?
Yes
No
Thursday, October 30th, 2008 AT 5:17 PM

3 Replies

Tiny
MHPAUTOS
  • EXPERT
Hi there,

You may have a faulty new pump, a blocked pick up I would be checking this out, did you replace the filter? And clean the tank when you replaced the pump?

Mark (mhpautos)
Was this
answer
helpful?
Yes
No
Thursday, October 30th, 2008 AT 5:24 PM
Tiny
MDM6713
  • MEMBER
Thank for the reply. Can anyone confirm how to bench test the pump? Ive heard it should pump a quart in 30secs? I suspect a weak pump (aftermarket) Does seem to have the "back" to push the fuel uphill. Any advice from here is greatly appreciated.
Thanks
Michael
Was this
answer
helpful?
Yes
No
Thursday, October 30th, 2008 AT 5:46 PM
Tiny
ACTION JACKSON1960
  • MEMBER
Hey guy i'm on my third pum 2nd aftermaret (napa) pump. It sounds like you missed on trouble shooting. When my pumps went it didn't pump till replaced. The 2nd pump has worked good for a year.
Was this
answer
helpful?
Yes
No
Saturday, December 6th, 2008 AT 4:32 PM

Please login or register to post a reply.

Sponsored links