Impossible Engin Start-up and sometimes the engine dies when driving + Black smokes -not always-

Tiny
ACHIBANI
  • MEMBER
  • 2005 KIA SORENTO
  • 192,000 MILES
Hi Gents;

Recently I started experiencing a set of problems with my 2005 KIA Sorento, first it was hardly strating-up, it takes many seconds; after that there were some black smokes when it starts-up and some times when on 1st gear even 2nd.

but now after few weeks of this life, I started having issues with my car when driving, the engin lose power then it dies suddenly! When I try to re-start it up. It just don't!

when I went to the mecanics garage, they told me that it's an injector problem, I changed them -the 4 of them- not just this, I changed the HP Mano and air-filter and so many other staff! But always having the same problem; my car always still have issues of starting-up and it does with anti-insect blow right in the air-filter "trough the engin side".

i really don't know what to do! I am really confused, and I really want some help over here! So if there any suggestions, please don't hesitate, and if any other info is required, please feel free to contact me.

Thanks in advance and best regards.

Abdelhak.
Do you
have the same problem?
Yes
No
Sunday, September 2nd, 2012 AT 10:32 PM

3 Replies

Tiny
SATURNTECH9
  • EXPERT
Has anyone checked the coolnt temp sensor yet?Also any codes in the computer?
Was this
answer
helpful?
Yes
No
Sunday, September 2nd, 2012 AT 10:36 PM
Tiny
ACHIBANI
  • MEMBER
Well not yet, eventhought im not sure but I dont think so, for the codes; I think i've got a P1118 once! Any ideas?
Was this
answer
helpful?
Yes
No
Sunday, September 2nd, 2012 AT 10:42 PM
Tiny
SATURNTECH9
  • EXPERT
Are you sure it wasn't a P0118?Because that is for a coolant temp sensor issue.
Was this
answer
helpful?
Yes
No
Monday, September 3rd, 2012 AT 7:42 PM

Please login or register to post a reply.

Recommended Guides