Cranks but does not start

Tiny
REDHAT4U2
  • 2004 FORD IKON
  • 75,000 MILES

HI,
I have the 1.6 engine and it is the NXT model. My car is not starting. Engine cranks up but not start. Checked plugs and all fuses every thing works fine. Later a mechanic inspected and said that the fuel pump not running and tried to direct the fuel pump motor and it worked fine. Now the fuel pump also works only when the fuse is toggled and direct line is given but car does not start. The ignition key not engaging the fuel pump by itself and subsequently current not supplied to ignition coil. And engine does not start. Fuel pump and ignition coil should work together when key is inserted which does not happen. Please help. Is it the problem with ECU or some electrical line?

I did a through check with the help of electrical engineer I advised him about the reply you gave me and he did a complete check on fuse box and holder by using altimeter and also using a spare wire connected to a bulb and every fuse works fine because the bulb glows on touching every fuse holder. Now he saw some thing strange and told me which even I would like to share with you. One of the relay switches behind the fuse box is not engaging when key is inserted in ignition this relay is meant for fuel pump and engine management this has four pins two big pin and two small pins. First big pin current supply not happening.

Second big pin supply is good and in one of the small pin whose connection is with fuel motor and ACM box is also not working. Mechanic told me it might be issue with some sensor of the car which is not supplying current to ignition coil and even the spark plug wire is not supplying sparks when engine is cranked by key to start. I am so confused at least if I determine which part is a failure I shall purchase that, but no one here is able to identify the part itself. Waiting for your reply.

Do you
have the same problem?
Yes
No
Saturday, January 12th, 2013 AT 7:09 PM

13 Replies

Tiny
DRCRANKNWRENCH
  • EXPERT
  • 3,443 POSTS

It sounds like the crankshaft angle sensor is not seeing the engine turn over so the computer will not turn on the fuel pump. This is easy to change it takes about 30 minutes. Here is a guide that will help you see what you are in for when doing the job. (Yours is much easier)

Here is how it is done on your car (below)

You will need to jack the car up first.

https://www.2carpros.com/articles/jack-up-and-lift-your-car-safely

Please let us know what happens.

Cheers

Was this
answer
helpful?
Yes
No
Sunday, January 13th, 2013 AT 6:08 AM
Tiny
CTASQUIER
  • MEMBER

When you turn the ignition on is there a red light security flashing next to the clock?

Was this
answer
helpful?
Yes
No
+10
Wednesday, January 16th, 2013 AT 8:55 PM
Tiny
REDHAT4U2
  • MEMBER

Dear sir,

There is no clock in this car's dash board and yes the lights which glows red are hand break, battery and fuel which turns red when the ignition switch is on and later goes off when engine use to start. Would also want to let you know that during these days we did managed to start the engine cause the sensor attached to speedometer was short circuited and the wires were burnt. We were also connecting the earthing line to battery on positive terminal which was not allowing the current to pass, but now since we removed the speedometer sensor cable and connected the wire to -ve terminal the car started and yes we also exchanged ECM box from a running car, which engaged the relay and helped to start the engine. However, the problem is that the engine starts up with a weird sound like as if it is a diesel engine and is throwing lot of black smoke and does not stay on if accelerator is not pressed half. Could it be again the problem with ACM box not supplying enough current to fuel motor or is the fuel motor also gone bad? Waiting for your reply. Kindly help.

Was this
answer
helpful?
Yes
No
+1
Thursday, January 17th, 2013 AT 3:25 AM
Tiny
CTASQUIER
  • MEMBER

Is it Rocam engine?
What kind of ECU does it have? Bosch, Motronic or other?

Was this
answer
helpful?
Yes
No
+2
Thursday, January 17th, 2013 AT 5:08 AM
Tiny
REDHAT4U2
  • MEMBER

Yes sir it is Rocam engine Ford ikon nxt ZXI 1.6. the ECU Manufacturer is MYCO has 60 pin part number is XS6F-12A650-JC. I changed the crankshaft sensor and it worked nice work guys.

Here is the part I put in on Amazon for $26.00 bucks

https://www.amazon.com/gp/product/B000C5FIWI/ref=as_li_qf_sp_asin_il_tl?ie=UTF8&tag=2carprcom-20&camp=1789&creative=9325&linkCode=as2&creativeASIN=B000C5FIWI&linkId=8f5a20e7a839ebd6444c26eeec2b2072

Was this
answer
helpful?
Yes
No
Thursday, January 17th, 2013 AT 4:03 PM
Tiny
CTASQUIER
  • MEMBER

If it was an ECU problem, unfortunately I do not have enough knowledge on that ECU to give you the pin out diagram for you to test. Good thing the sensor fixed it, nice work

Was this
answer
helpful?
Yes
No
Friday, January 18th, 2013 AT 5:53 AM
Tiny
DRCRANKNWRENCH
  • EXPERT
  • 3,443 POSTS

I would check all the ECU connectors for corrosion as well as connectors. Is there any chance this car came from an auction or second hand dealer because it has the sorts of problems that a flooded car would have? Several mysterious electrical shorts and issues.

I am going to give you a diagnostic on causes for black smoke coming out of the exhaust. Just use the link at the end. Also, have the fuel pressure checked to see what it is. The link for black smoke out of exhaust is:

http://www.2carpros.com/articles/engine-black-smoke

and here is a don't start link that has helped me alot

https://www.2carpros.com/articles/car-cranks-but-wont-start

Let me know how things go and we can move from here.

Was this
answer
helpful?
Yes
No
-1
Saturday, January 19th, 2013 AT 5:40 PM
Tiny
ALLAVDIN
  • 2004 FORD IKON
  • 4 CYL
  • FWD
  • MANUAL
  • 127,000 MILES

My ford ikon 1.8d having starting problem in cold condition how to solve the problem

Was this
answer
helpful?
Yes
No
+1
Friday, August 25th, 2017 AT 4:27 PM (Merged)
Tiny
RASMATAZ
  • MEMBER

Get a helper disconnect a sparkplug wire or 2 and ground it to the engine atleast 3/16 away from ground-have helper crank engine over-do you have a snapping blue spark? If so-you have a fuel related problem, Do you hear the fuel pump come On when you turn key on? If not check fuel pump fuse and fuel pump relay if okay-check the fuel pressure to rule out the fuel filter/fuel pump/pressure regulator and listen to the injector/s are they pulsing or hook up a noid light. No snapping blue spark continue to troubleshoot the ignition system-power input to the coil/coil packs, coil's resistances, cap and rotor, distributor pick-up coil, ignition control module, cam and crank sensors and computer Note: If it doesn't apply disregard it and keep testing.

Was this
answer
helpful?
Yes
No
Friday, August 25th, 2017 AT 4:27 PM (Merged)
Tiny
SHOERA007
  • 2004 FORD IKON
  • 137,000 MILES

It stalled while driving and does not want to start. It switches on, but it does not start.

Was this
answer
helpful?
Yes
No
Friday, August 25th, 2017 AT 4:27 PM (Merged)
Tiny
BMRFIXIT
  • EXPERT
  • 19,464 POSTS

Check basic 1st
do you have fuel and fuel pressure
check for spark
check timing
check fuses
check for codes
let us know what is missing

Was this
answer
helpful?
Yes
No
-1
Friday, August 25th, 2017 AT 4:27 PM (Merged)
Tiny
NJ_895
  • 2004 FORD IKON
  • 1.8L
  • 4 CYL
  • 2WD
  • MANUAL
  • 18 MILES

Best suitable glow plugs? (Good brands )
Best suitable suspension system for front and rear?
Can turbo be installed in this engine?
Air conditioner looses cooling every 3 to 4 months after gas charging

Was this
answer
helpful?
Yes
No
Friday, August 25th, 2017 AT 4:27 PM (Merged)
Tiny
AHMER AMMAR
  • MEMBER

Please check your engine compression rete if its 9 or more than it so you can install it if its below so you can't.

Was this
answer
helpful?
Yes
No
Friday, August 25th, 2017 AT 4:27 PM (Merged)

Please login or register to post a reply.

Recommended Guides