CAR START BUT DIE RIGHT AWAY WHEN IS COLD WEATHER

2002 Saturn SL2

Tiny

joseviz1979

October, 9, 2012 AT 11:01 PM

Hello there I got a saturn sl2 2002 run great when is warm weather but on the mornings whenthe weather is cold the engine start but it die right away no sure what could be the problem

FOUND 24446 RELATED QUESTIONS

Cj Stalling When Idling

33 ANSWERS
50 IMAGES

Stalling Out

43 ANSWERS
52 IMAGES

21 Answers

Tiny

saturntech9

October, 9, 2012 AT 11:08 PM

Sounds like a bad coolant temp sensor and possibly bad connector. Do ever have to hold the gas pedal to the floor to start it?Any codes in the computer?

Tiny

joseviz1979

October, 9, 2012 AT 11:28 PM

Holding the gas pedal to the floor work for a couple time now when I do it it dont start at all wihtout holding it start but die right away sometimes the security light come on but go away soon adn I havent take to scaner yet

Tiny

saturntech9

October, 9, 2012 AT 11:39 PM

I would change the coolant temp sensor also inspect the inside of the coolant temp sensor connector if the terminals are green or blue instead of silver replace the connector also. As far as the security light on thats a seperate issue. You will need to have a advanced scan tool scan your body control module for codes.A basic obd2 reader/scanner wont read the body control module.

Tiny

joseviz1979

October, 9, 2012 AT 11:45 PM

Ok I will try that thanks

Tiny

saturntech9

October, 9, 2012 AT 11:47 PM

Your welcome keep me posted.

Tiny

joseviz1979

October, 12, 2012 AT 12:08 PM

Hello there well I replaced the coolant sensor and the conector look good but it didnt fix the problem car run good on warm weather but morning when is cool wont stay on what could be

Tiny

saturntech9

October, 12, 2012 AT 7:24 PM

Replacing that sensor is the number one fix for that issue. Do you have any codes in the computer?Also the sensor connector terminals were silver?Also where was the sensor located you replaced and what was the part number of the sensor you put in?Just covering all my bases.

Tiny

joseviz1979

October, 12, 2012 AT 8:12 PM

No I dont have any codes the sensor was in the block under the hose than come from the radiator the part was the same I pull out I will have to look the part number

Tiny

saturntech9

October, 12, 2012 AT 9:08 PM

Alright let me know what the part number is.

Tiny

joseviz1979

October, 12, 2012 AT 9:21 PM

The part was Wt5029 no sure if that is the part number u talking about

Please login or register to post a reply.

Code Read Retrieval/Clear Mercedes Benz
Code Read Retrieval/Clear Mercedes-Benz C230
Code Read Retrieval/Clear Chevrolet Camaro
Code Read Retrieval/Clear - Dodge Stratus
Read Codes Like a Pro
Code Read Retrieval/Clear Scion XD