Heater core

Tiny
EMORSE
  • 1997 FORD EXPEDITION
  • V8
  • 4WD
  • AUTOMATIC
  • 140,000 MILES

I have a 97 ford expedition that I have replaced the heater core in the front 2 times about 6 months apart im stumped as to what could be causeing it. Any help would be great.

Do you
have the same problem?
Yes
No
Sunday, May 15th, 2011 AT 11:53 PM

5 Replies

Tiny
PROTECH1980
  • EXPERT
  • 928 POSTS

Changed it because it was leaking or because it keeps plugging up?

Was this
answer
helpful?
Yes
No
Monday, May 16th, 2011 AT 12:02 AM
Tiny
EMORSE
  • MEMBER

Its leacking almost like there is a build up of preasure. Tried flushing it both times too

Was this
answer
helpful?
Yes
No
Monday, May 16th, 2011 AT 12:05 AM
Tiny
PROTECH1980
  • EXPERT
  • 928 POSTS

Sounds like this could be caused by a chemical reaction called electrolysis within the coolant, check this link: http://www.4s.com/Upload/Four%20Seasons/documents/Tech%20Tips/English/4S%20350%20ELECTROLYSIS.PDF

Was this
answer
helpful?
Yes
No
Monday, May 16th, 2011 AT 12:16 AM
Tiny
EMORSE
  • MEMBER

I havent put the new one in yet but I will check that it said something about a nutralizer what would you ecomend to use if that is what I need?

Was this
answer
helpful?
Yes
No
Monday, May 16th, 2011 AT 12:25 AM
Tiny
EMORSE
  • MEMBER

Ok I tested the electrolysis level and I got a reading of.200 VDC
im going to clean the grounds anyway for safety but could there be anything else that would cause it

Was this
answer
helpful?
Yes
No
Monday, May 16th, 2011 AT 1:35 AM

Please login or register to post a reply.

Other Heater Core Replace/Remove Questions