No crank, no start, no fuel to injectors and getting no spark to coils

Tiny
MSTANLEY33569
  • MEMBER
  • 2004 FORD EXPEDITION
  • 4.6L
  • V8
  • 2WD
  • AUTOMATIC
  • 178,008 MILES
When I got this SUV previous owner told me that it ran good until one day it wouldn't start. So he had the starter and fuel pump replaced. Still wouldn't start. So I bought it for cheap and I completely went through the engine. I ended up rebuilding the engine, and when I was done I tried to start it, it still wouldn't turn over. So I checked the power distribution box and I replaced it with a used one from an auto salvage place. Replaced some fuses and relays still wouldn't turn over. I went and got a different ignition switch still nothing. I did rent a diagnostic plug in and it was saying that the PCM does not match the VIN. So I went and bought a new PCM with 2 new keys and I programmed the keys. I followed step by step directions on how to do it which was sent by the place where I purchased the computer. It cranked but wouldnt start, tried again and it doesn't do anything no crank no start. I'm not getting spark to coils and also not getting fuel to injectors, fuel pump is good I can hear it when I turn the key. What could be wrong?
Do you
have the same problem?
Yes
No
Saturday, February 29th, 2020 AT 5:10 AM

6 Replies

Tiny
KASEKENNY
  • EXPERT
Okay. Couple things first. You said it did crank and then you said it would not do anything. After you put the PCM and keys does it crank and not start? Meaning the engine spins over when starting it but it doesn't start.

https://www.2carpros.com/articles/car-cranks-but-wont-start

Next thing is we need to find out if we still have codes. The fact that we don't have spark or fuel sounds like a crank sensor issue. We can get into that when we find out what codes we have and clarify what it is doing now.

https://www.2carpros.com/articles/symptoms-of-a-bad-crankshaft-sensor
Was this
answer
helpful?
Yes
No
Saturday, February 29th, 2020 AT 8:11 AM
Tiny
MSTANLEY33569
  • MEMBER
That is correct. It cranked but did not start. So I tried again, and nothing. No crank no start.
Was this
answer
helpful?
Yes
No
Saturday, February 29th, 2020 AT 9:50 AM
Tiny
KASEKENNY
  • EXPERT
Okay. So if it will not do anything now, we need to see if the theft light is remaining on. If not, we need to got to the starter and see if we have voltage on the B+ and control wire when cranking the engine.

If the theft light is not on and we don't have voltage there, then we have either a fuse, wiring, or control (PCM) issue. However, with what you have done, I suspect the theft light is remaining on or flashing. If it is, we need to get codes so we can see why we are not getting past the theft system at this point.
Was this
answer
helpful?
Yes
No
Sunday, March 1st, 2020 AT 5:59 PM
Tiny
MSTANLEY33569
  • MEMBER
Okay, I will try that tomorrow and let you know.
Was this
answer
helpful?
Yes
No
Sunday, March 1st, 2020 AT 6:26 PM
Tiny
MSTANLEY33569
  • MEMBER
The theft like is staying on when I turn the key to crank.
Was this
answer
helpful?
Yes
No
Monday, March 2nd, 2020 AT 1:37 PM
Tiny
KASEKENNY
  • EXPERT
Okay. Then we need to check for codes or try to program the keys again. If trying to program the keys does not work, then we will have no choice but to check for codes to see why we are not getting past the theft system.

Without the codes then we will just be guessing at what the issue with the system could be.
Was this
answer
helpful?
Yes
No
Monday, March 2nd, 2020 AT 4:37 PM

Please login or register to post a reply.

Sponsored links