2000 Volvo S40 Dropping Idle When A/C Is On At Idle In Driv

Tiny
JKROSS
  • MEMBER
  • 2000 VOLVO S40
Engine Mechanical problem
2000 Volvo S40 4 cyl Front Wheel Drive Automatic

While at idle in drive my S40 idles just fine, but once you turn on the A/C the idle drops down to 500-600rpm and shakes like it is going to turn off. If you place the car in neutral the idle goes back up and idles normal again as well if you place in park. No lights on and car runs fine besides this.
Do you
have the same problem?
Yes
No
Wednesday, July 28th, 2010 AT 11:17 PM

11 Replies

Tiny
JIS001
  • EXPERT
Check the idle air control valve and clean it out. Let me know if that works.
Was this
answer
helpful?
Yes
No
Thursday, July 29th, 2010 AT 11:15 PM
Tiny
JKROSS
  • MEMBER
Cleaned it out on still no change.
Was this
answer
helpful?
Yes
No
Friday, July 30th, 2010 AT 1:47 PM
Tiny
JIS001
  • EXPERT
When you cleaned it out did you try and see if the valve was able to slide back and forth by moving it manually? If that was ok and you do not visaually see any vacuum leaks try scanning for codes. If no codes then you will need to replace the idle air control valve. Before you replace the valve try cleaning the throttle body also. Sorry forgot to mention that on my last reply?
Was this
answer
helpful?
Yes
No
Saturday, July 31st, 2010 AT 12:27 AM
Tiny
JKROSS
  • MEMBER
The valve moved back and forth just fine, I scanned it and received code for MAF / VAF CKT.
Was this
answer
helpful?
Yes
No
Sunday, August 1st, 2010 AT 8:24 AM
Tiny
JIS001
  • EXPERT
What were the fault codes scanned?
Was this
answer
helpful?
Yes
No
Monday, August 2nd, 2010 AT 12:31 AM
Tiny
JKROSS
  • MEMBER
I misplaced the paper I wrote it on, it said after the numbers:
MAF / IAF CKT
Was this
answer
helpful?
Yes
No
Monday, August 2nd, 2010 AT 12:39 AM
Tiny
JIS001
  • EXPERT
Can you get it rescanned?
Was this
answer
helpful?
Yes
No
Monday, August 2nd, 2010 AT 12:49 AM
Tiny
JKROSS
  • MEMBER
I will take it down either tomorrow or Tuesday and get back with you.
Was this
answer
helpful?
Yes
No
Monday, August 2nd, 2010 AT 12:51 AM
Tiny
JKROSS
  • MEMBER
The code is P0101 MAF or VAF ackt
Was this
answer
helpful?
Yes
No
Tuesday, August 3rd, 2010 AT 3:45 PM
Tiny
JIS001
  • EXPERT
Get a volt meter and back probe the mass air flow sensor signal wire. At idle you should see aproximate 0.6 volts. The voltage should increase when you accelerate. If that is ok then I would suspect a bad map sensor under the fuel rail cover. Back probe the signal wire and with key on only you should see 1.8 volts and with engine idle you should see close to 0.7 volts. If you are not close those numbers replace the map sensor. They cause a lot of driveability problems and setting off Mass Air Flow sensor codes when they are giving faulty information. The mass air flow sensor uses the map sensors signal so then there becomes conflict when one or the other is wrong. Keep me posted and let me know what you find and hope the info helps? Also the signal for MAF is pin#2 and pin #3 for MAP sensor. Also you posted another definition? Did you have more then one code? If you do have other codes posted or pending let me know? If you do and the fault is for sensors that are in the same circuit then most likely fault will be a bad A/C high pressure sensor. I believe the A/C pressure sensor is some how connected to the MAP sensor, Throttle Position Sensor, Altitude Sensor? Maybe why it only acts up when the A/C is on now that I am giving it some more thought? Check the first 2 things and let me know what you find?
Was this
answer
helpful?
Yes
No
Tuesday, August 3rd, 2010 AT 9:31 PM
Tiny
JKROSS
  • MEMBER
Thanks for all the help, I ended up just selling the vehicle today.
Was this
answer
helpful?
Yes
No
Monday, August 16th, 2010 AT 6:38 PM

Please login or register to post a reply.

Recommended Guides