Upper control arms and ball joints

Tiny
JJAMESJR
  • MEMBER
  • 2007 CHEVROLET TAHOE
  • V8
  • 4WD
  • AUTOMATIC
  • 135,000 MILES
I just replaced my upper control arms and ball joints on my SUV and now they make a very loud clunking noise when I am in reverse as well as when I turn the wheel. I tightened everything to spec and compared the old parts to the new and as far as I can tell they looked the same. I even called the place that I purchased the parts from to confirm that I got the right parts and they said that I did. I do not feel like the vehicle is safe to drive and I have no idea what the solution is and I could use some help. I matched the cam plates as well and I believe everything was installed correctly. Is there any chance that both new control arms are faulty? I could not imagine they both are but I have no clue why it is doing this. I only changed these in the first place to fix the up and down motion I had while driving I knew the ball joints were worn, they never made any kind of noise before the install. Also, I installed the grease fitting and filled with grease until the boot expanded as well.
Do you
have the same problem?
Yes
No
Thursday, October 25th, 2018 AT 11:15 AM

1 Reply

Tiny
ASEMASTER6371
  • EXPERT
Good afternoon.

Did you remove the axles? If you did, how about the nut holding in the outer joint. Did you torque it to specs? It should be 180-200 ft lbs.

Did you replace the stabilizer link kits and frame bushings? Check for any play.

Roy

https://www.2carpros.com/articles/popping-noise
Was this
answer
helpful?
Yes
No
Thursday, October 25th, 2018 AT 2:11 PM

Please login or register to post a reply.

Sponsored links