Turn signal issues

Tiny
JON SCHRADER
  • MEMBER
  • 2003 CHEVROLET IMPALA
  • 3.8L
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 194,000 MILES
If you turn turn signal on, four way switch makes odd vibrating noise but no signals work.
Do you
have the same problem?
Yes
No
Wednesday, December 6th, 2017 AT 4:21 PM

6 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
It sounds like a bad flasher. Take a look at this and let me know if it helps.

https://www.2carpros.com/articles/turn-signals-not-working-blinker
Was this
answer
helpful?
Yes
No
Wednesday, December 6th, 2017 AT 7:40 PM
Tiny
JON SCHRADER
  • MEMBER
Changed switch and accessories relay and no help it is actually got more issues now lol. The four way dash lights and fog light switch stay on and they are not on, and now is no turn over just blinks lights.
Was this
answer
helpful?
Yes
No
Thursday, December 7th, 2017 AT 6:04 AM
Tiny
JON SCHRADER
  • MEMBER
Body control module?
Was this
answer
helpful?
Yes
No
Thursday, December 7th, 2017 AT 6:05 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Possibly. However, since things are not turning off, it sounds like maybe a short to power. Check the wiring in and around the fuse block under the hood. Also, if you have not replaced the four way switch, that could be the problem.
Was this
answer
helpful?
Yes
No
Thursday, December 7th, 2017 AT 6:10 PM
Tiny
JON SCHRADER
  • MEMBER
Just wanted to check back to let you know it ended up being my ignition switch smh never would have guessed but smarter minds and equipment got me figured out, thanks for your help though and maybe this will help out someone else when their Impala starts acting up.
Was this
answer
helpful?
Yes
No
Monday, January 1st, 2018 AT 4:47 PM
Tiny
KEN
  • ADMIN
Glad you could get it fixed, that kind of problem can be tough. Please use 2CarPros anytime we are here to help

Cheers, Ken
Was this
answer
helpful?
Yes
No
Wednesday, January 3rd, 2018 AT 8:38 PM

Please login or register to post a reply.

Recommended Guides