Stabil track light is on and the engine does not crank?

Tiny
CHRISTIANH
  • MEMBER
  • 2010 CHEVROLET CAMARO
  • 3.6L
  • V6
  • 2WD
  • AUTOMATIC
  • 123,000 MILES
I got in my car to drive to work everything was fine until I got out to lock my car, it wouldn’t fully beep. I got back in my car to try and turn it over and check it out and the Stabil Trak light was on, and my car wouldn’t turn over or even click at all! The voltages on the battery are up I don’t see any loose connections.
Do you
have the same problem?
Yes
No
Tuesday, September 27th, 2022 AT 8:10 AM

1 Reply

Tiny
KEN L
  • ADMIN
With the voltmeter on the battery turn the key on and try to crank the engine over while watching the meter, if the voltage drops below 10 voltage the battery is bad and needs replacement. Here is another way to load-test the battery without equipment:

https://www.2carpros.com/articles/car-battery-load-test

This guide may help as well:

https://www.2carpros.com/articles/starter-not-working-repair

If the battery is okay, we need to run the codes.

https://www.2carpros.com/articles/checking-a-service-engine-soon-or-check-engine-light-on-or-flashing

I not codes are present it sounds like the starter has gone bad here is how you can change it out in this generic guide with instructions below to show you how on your car:

https://www.2carpros.com/articles/how-to-replace-a-starter-motor

Check out the images (below). Please let us know what you find. We are interested to see what it is.

Was this
answer
helpful?
Yes
No
Tuesday, September 27th, 2022 AT 11:35 AM

Please login or register to post a reply.

Sponsored links