Speedometer cluster head failure

Tiny
MATT DAVIDSON
  • MEMBER
  • 1996 CHEVROLET 1500
  • 5.7L
  • V8
  • 4WD
  • AUTOMATIC
  • 211,000 MILES
No speedometer, tachometer, or odometer but all other gauges working. Will not take off in first but can shift to first manually. Changed speed sensor on transfer case no change. Cluster looks fine when removed. Cannot find issue.
Do you
have the same problem?
Yes
No
Saturday, March 31st, 2018 AT 3:53 PM

3 Replies

Tiny
KEN
  • ADMIN
Hmm,

Can we run the codes to see what comes up? Here is a guide. Have you checked the fuses?

https://www.2carpros.com/articles/how-to-check-a-car-fuse

and

https://www.2carpros.com/articles/checking-a-service-engine-soon-or-check-engine-light-on-or-flashing

Check out the diagrams (below).

Please let us know what you find.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Monday, April 2nd, 2018 AT 11:17 AM
Tiny
MATT DAVIDSON
  • MEMBER
Checked all fuses and have already ran codes. Only codes throwing are o2 sensor, a misfire, and shift solenoid.
Was this
answer
helpful?
Yes
No
Monday, April 2nd, 2018 AT 11:42 AM
Tiny
KEN
  • ADMIN
Bad sign, it sounds like the PCM is no good or the cluster. but first lets do a wiring check before we change either out.

https://www.2carpros.com/articles/how-to-check-wiring

Check all power and grounds.

Check out the diagrams (below).

Please let us know what you find. We are interested to see what it is.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Tuesday, April 3rd, 2018 AT 10:52 AM

Please login or register to post a reply.

Sponsored links