Speed sensors location needed

Tiny
HARLIE GOSWICK
  • MEMBER
  • 2010 NISSAN ALTIMA
  • 2.5L
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 1,500,000 MILES
Car speedometer wont work. Car locks in first gear and every light comes on. We changed the speed sensor the inhaler looking one can't find the $20.00 sensor (the stick looking one with the spinning end) location. Checked the wiring harness and ABS, also checked fluids. I don't know what else to do can't afford to go to a mechanic. I need help.
Do you
have the same problem?
Yes
No
Friday, September 10th, 2021 AT 11:15 PM

1 Reply

Tiny
KASEKENNY1
  • EXPERT
You are talking about the vehicle speed sensor. However, this vehicle does not use a speed sensor with a gear on the end that generates the speed signal.

Your vehicle uses the ABS module which picks up the wheel speed sensor info and sends a message to the cluster to display the speed.

It uses what is called a CAN communication signal. Here is a guide that talks more about this:

https://www.2carpros.com/articles/can-scan-controller-area-network-easy

The fact that you have the different issues, I suspect we have some codes that will point us to what the issue is.

Please use this guide to help with getting codes:

https://www.2carpros.com/articles/checking-a-service-engine-soon-or-check-engine-light-on-or-flashing

Also, below is the info from the manual on how this works. So I would suggest starting with codes and we can figure out next steps.

Thanks
Was this
answer
helpful?
Yes
No
Saturday, September 11th, 2021 AT 8:33 AM

Please login or register to post a reply.

Sponsored links