Sputters when trying to accelerate will not go over 20 mph

Tiny
LATARA LVNMYBABIES USHER-WHIGHAM
  • MEMBER
  • 2006 FORD EXPEDITION
  • V8
  • 2WD
  • AUTOMATIC
  • 290,000 MILES
I drove my truck 30 minutes away from my house. It drove find. I got back home had to stop at red light once I went to take off my truck wouldn't go over 20 mph it sputters as I gave it gas, so I cruise home doing 20 mph when cruising and it hit 25 mph truck would rev unnnnnn sound when I dropped back down to 20 ride smooth. Please help me. Is this my fuel pump or transmission? As I can't replace transmission. I'm so hoping it is not the transmission. Please help me I'm a single mother of six.
Do you
have the same problem?
Yes
No
Friday, October 25th, 2019 AT 9:01 PM

5 Replies

Tiny
ASEMASTER6371
  • EXPERT
Good morning,

Did you check the fluid level in the transmission?

https://www.2carpros.com/articles/automatic-transmission-problems

How long since you changed the fluid and filter in the transmission?

https://www.2carpros.com/articles/how-to-service-an-automatic-transmission

Are there any codes set for a check engine light?

Roy
Was this
answer
helpful?
Yes
No
Saturday, October 26th, 2019 AT 5:51 AM
Tiny
LATARA LVNMYBABIES USHER-WHIGHAM
  • MEMBER
It has been a while since filter has been change. Fluids look okay. Have to take it to shop at 1:00. I was going to ask him to check everything. Will get back with you ASAP. Thanks for replying.
Was this
answer
helpful?
Yes
No
Saturday, October 26th, 2019 AT 8:32 AM
Tiny
LATARA LVNMYBABIES USHER-WHIGHAM
  • MEMBER
Check engine light is not on.
Was this
answer
helpful?
Yes
No
Saturday, October 26th, 2019 AT 8:33 AM
Tiny
ASEMASTER6371
  • EXPERT
Okay. Keep me updated.

Roy
Was this
answer
helpful?
Yes
No
Saturday, October 26th, 2019 AT 9:49 AM
Tiny
ASEMASTER6371
  • EXPERT
Did you post a response? I got an email for a response but nothing showed up.

Roy
Was this
answer
helpful?
Yes
No
Sunday, October 27th, 2019 AT 5:21 AM

Please login or register to post a reply.

Sponsored links