Radio will not light up or work at all

Tiny
THEB0YZ
  • MEMBER
  • 2008 ACURA MDX
  • 3.8L
  • 6 CYL
  • AWD
  • AUTOMATIC
  • 72,000 MILES
Drove car, everything was operational. The radio does not light up or turn on. Nothing shows in the display for temperature or time either. We checked the fuses, and they seemed to be okay. Any assistance will be greatly appreciated.
Do you
have the same problem?
Yes
No
Tuesday, December 3rd, 2013 AT 5:40 PM

4 Replies

Tiny
TY ANDERSON
  • EXPERT
Usually when a specific component doesn't work there is a circuit issue or the component itself.
Has the battery been jumped or any accessories been added? Replacing the battery will put the radio into a security mode requesting a code to regain any functionality. Any aftermarket components installed like a dvd player, blue tooth, radio, etc?

If the fuses are good (refer to the owner's manual for each fuse box, because there is usually more than one) and the circuits to the radio and time good then its the radio and compass/time units that are bad.
Let me know if you have any questions.
Was this
answer
helpful?
Yes
No
Tuesday, December 3rd, 2013 AT 7:25 PM
Tiny
THEB0YZ
  • MEMBER
Thank you for responding, no nothing has been added. Everything is stock. Battery was replaced in early Spring 2013. Does not ask for code, all backlights on radio are out. Completely dark. The only thing that shows on the display is that the Bluetooth was connected. Time or temperature did not show at all either. My husband checked the fuses and said they are good, he will have to pull the radio I guess to check and see if there is voltage to the radio, but that will have to wait for the weekend, I guess. :( So strange, but I guess if things are electrical, anything is possible. I appreciate your time and insight to this situation.
Was this
answer
helpful?
Yes
No
+1
Tuesday, December 3rd, 2013 AT 8:28 PM
Tiny
MANNU101
  • MEMBER
Did you find the answer to your problem? The same thing seems to be happening to me too. Electric door locks, fob, nav system and audio system don't seem to work. Can't be fuse because they are on different circuits. Not sure what to do.
Was this
answer
helpful?
Yes
No
-1
Sunday, January 12th, 2014 AT 9:10 AM
Tiny
THEB0YZ
  • MEMBER
Actually, after checking all fuses with tester and they all tested as if they were working, my husband pulled the fuses related to radio, I think there were 4 all together, pulled them out and pushed them in again, and by some stroke of luck, just as I was looking up how to remove the radio from the dash, CD's that were in the radio began making "noise", so we got the key, turned the power on and the radio asked for the code as well as the nav system asking for the code, knock on wood, everything has been working perfectly ever since. Do not know what happened to cause it, just happy we did not need to purchase the radio at an estimated cost of at least $800. Good Luck!
Was this
answer
helpful?
Yes
No
-1
Sunday, January 12th, 2014 AT 9:17 AM

Please login or register to post a reply.

Recommended Guides