Radio not working

Tiny
ELIZABETH ELLEDGE
  • MEMBER
  • 2001 CHEVROLET IMPALA
  • 175,000 MILES
Cannot get the radio to come on. When I use my headlights and the dash glows the radio does too but there is still no sound. All my fuses are fine and the battery is new. Not sure what is going on.
Do you
have the same problem?
Yes
No
Saturday, May 20th, 2017 AT 9:36 AM

2 Replies

Tiny
KEN
  • ADMIN
Hello,

This can be one of two problems, either the radio is not working becasue of a issue inside the unit or the ground or power circuit needs to be checked and fixed.

Here is a wiring diagram and a guide so you can do some testing to be sure on whats the problem.

https://www.2carpros.com/articles/how-to-use-a-test-light-circuit-tester

and

https://www.2carpros.com/articles/how-to-check-wiring

Please let us know what you find ;)

Cheers, Ken

Was this
answer
helpful?
Yes
No
Monday, May 22nd, 2017 AT 11:45 AM
Tiny
STEVE W.
  • EXPERT
Is this the factory radio? Do you see it turn on, change channels or CD/Tape functions all work, just no sound? If so the amp in the rear has probably failed or the ground or power to it is bad. Easy way to test those is to look at the wiring diagram and locate the Orange wire (battery positive) and the Black wire (ground) You can bare a spot on the black wire and run a short section of similar wire to a good ground in the back or take it to the battery negative post. Do you now have sound? If so the ground wire has broken. If nothing yet, bare a spot on the orange wire and run a wire from it to the positive battery post. Do you have sound now?

If neither of those get the sound back it is either the amp on output in the head unit OR the amp is bad.
Was this
answer
helpful?
Yes
No
Tuesday, May 23rd, 2017 AT 3:01 PM

Please login or register to post a reply.

Recommended Guides